Pontiac G6 Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
235 Posts
Discussion Starter #1
I got in the car last night and turned on the fogs lights and I noticed the little light inside the button was flashing. I thought maybe I had not fully hit the buttom so I pushed it again and it turned the fog lights off. So I pushed it again to turn the fog lights back on and now the light inside the button no longer works. I checked again this morning to make sure it was still not working and it wasn't. I am wondering since this light stopped working what else will stop working that may be connected to it. Anyone else notice this? Fogs lights still work as of now, just not the light in the fog light button.
 

·
Registered
Joined
·
39 Posts
When you say the button was flashing, was a consistent flashing, like a blinking? Or was it more flickering on and off? If it was just flickering, it could just be a bad connection to the LED light. If it was steadily blinking, then it almost seems like an indicator for something. However, if something was actually wrong, you would think that a light on the dash would go on instead of a little bit of flashing from the foglight button.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #3
carsuperfreak said:
When you say the button was flashing, was a consistent flashing, like a blinking? Or was it more flickering on and off? If it was just flickering, it could just be a bad connection to the LED light. If it was steadily blinking, then it almost seems like an indicator for something. However, if something was actually wrong, you would think that a light on the dash would go on instead of a little bit of flashing from the foglight button.
It was flickering before it completely stopped. :eek:
 

·
Registered
Joined
·
73 Posts
Not sure on the new lighting, but on the old switches the light in the switch gets its power from the power that's feeding into the switch, and you have to have a ground wire connected to complete the circuit. Maybe it's as simple as a wire cut somewhere, but then you have to ask why or how?
 

·
Registered
Joined
·
423 Posts
Robyn P said:
I got in the car last night and turned on the fogs lights and I noticed the little light inside the button was flashing. I thought maybe I had not fully hit the buttom so I pushed it again and it turned the fog lights off. So I pushed it again to turn the fog lights back on and now the light inside the button no longer works. I checked again this morning to make sure it was still not working and it wasn't. I am wondering since this light stopped working what else will stop working that may be connected to it. Anyone else notice this? Fogs lights still work as of now, just not the light in the fog light button.
the 'flashing light' on your Foglight Switch means the following;

"Ms Robyn P, if you or any of your Robyn P Family become upset with this vehicle, GM will disavow any knowledge of wrongdoing and your G6 will self-destruct in 60 seconds" :eek: .....Good Luck, Robyn P!!!
 

·
Registered
Joined
·
235 Posts
Discussion Starter #7
G6Action said:
the 'flashing light' on your Foglight Switch means the following;

"Ms Robyn P, if you or any of your Robyn P Family become upset with this vehicle, GM will disavow any knowledge of wrongdoing and your G6 will self-destruct in 60 seconds" :eek: .....Good Luck, Robyn P!!!

:D :D :D
 

·
Registered
Joined
·
61 Posts
Robin, You wouldn't happen to be in Nashville, would you? I swear they have every inch of their freeway system torn up at the same time!! It is so bad I don't even want to drive the G6 when I have to go there.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #9
PCB said:
Robin, You wouldn't happen to be in Nashville, would you? I swear they have every inch of their freeway system torn up at the same time!! It is so bad I don't even want to drive the G6 when I have to go there.

I live about an hour from Nashville. I think the majority of the roads in Tennessee are tore up. It drives me nuts!!
 

·
Registered
Joined
·
235 Posts
Discussion Starter #11
scsgoal31 said:
I have the same dead light issue, happened around 10 Months/9K Miles

I've had mine 9 months and it's got 7000 miles on it. It makes no sense. I guess it's not that big of a deal, but you don't expect things like that to stop working after 9 months. Going tomorrow to try to trade, again!! :D Wish me luck!!
 

·
Registered
Joined
·
423 Posts
Robyn P said:
I've had mine 9 months and it's got 7000 miles on it. It makes no sense. I guess it's not that big of a deal, but you don't expect things like that to stop working after 9 months. Going tomorrow to try to trade, again!! :D Wish me luck!!
hey, Good Luck!!! what are you looking at NOW?
 

·
Registered
Joined
·
235 Posts
Discussion Starter #15
G6Action said:
hey, Good Luck!!! what are you looking at NOW?
I'm trying to get back in an Xterra, but right now I'm upside down and it seems that all the dealers around Tennessee are crooks. Two quoted me a 600 payment, then I found another dealer that was getting me a black 05 Xterra for 4000 less than the others and giving me the same for my trade as the others and this dealership still came up with a 600 dollar payment. One tried to force me into a 4 cyclinder Altima. He was like, "oh it's got leather and nice rims". I told him I was in a GT and I was not going to trade down. I'm not happy with my G6, but I'm not that unhappy!! As of right now I'm just going to have to learn to live with it. Summer was OK with it, but with Winter coming I'm afraid of it. Last year I had my Xterra and I felt like I could go in the snow, but the G6 scares me, especially with the steering lock. :eek:
 

·
Registered
Joined
·
39 Posts
Sorry to hear you're not enjoying your G6 as much as others around here, but glad to hear you're getting something you'll hopefully like.

Happy Birthday by the way!
 

·
Registered
Joined
·
21 Posts
You all jinxed me!!!

After just 10 months and under, I think, 9000 miles my fog light switch led went out tonight. It was working just lastnight and now tonight, nothing. Damn it ALL! I was having such good luck and not having any issues until I started reading about them here. :mad:

Oh well, I guess the next oil change they will be taking care of that issue as well.
 

·
Registered
Joined
·
21 Posts
Yet again...

Yeah it was working again and then I turned off the rear defrost and shortly after that the led on fog light switch went out again. This is getting strange.

It works sometimes and other times it does not. Really strange. I need to quit reading about other issues before something big happens. :glasses3:
 
1 - 20 of 34 Posts
Top