Pontiac G6 Forum banner
1 - 20 of 40 Posts

·
Pushing Overload
Joined
·
88 Posts
Discussion Starter · #1 ·
Got them both today. I didn't expect the tcm but hey. Anyway, do I really need to put the tcm in? Will it make much more difference with it in? I got the 93 tune if that matters. I'm going to try and do this tomorrow at lunch unless I have to pull the tcm too.
 

·
Pushing Overload
Joined
·
88 Posts
Discussion Starter · #3 ·
Thanks Lamp! I'll prolly wait 'til this weekend then. Not enough time to pull the intake to get at it during lunch. lol

Thanks!
 

·
Premium Member
Joined
·
5,356 Posts
remember you may need a key relearn and a crank relearn too.
Depending on your year. Contact your tuner for verification.

I know most who put one in then try it without are like...MY CAR IS DEAD!!!! lol
 

·
Pushing Overload
Joined
·
88 Posts
Discussion Starter · #5 ·
Yikes, ya mean it wouldn't run at all until the relearn? I've heard so many different stories that it would still run but throw the code until you did the relearn? I better go ahead and order a dashhawk first. lol
 

·
Premium Member
Joined
·
5,356 Posts
You can borrow mine if your close to SA....
 

·
Pushing Overload
Joined
·
88 Posts
Discussion Starter · #7 ·
Actually in Tulsa. Thanks though for the offer! I ordered one from Amazon for 249.00. It'll be fun to have anyway. :)
 

·
Pushing Overload
Joined
·
88 Posts
Discussion Starter · #8 ·
Got my DashHawk in. Looks like I'll be able to get my new tune installed tomorrow!! I'll fun a 0-60 before and after and see how the new tune changes things.

BTW, should it run sort of hot when plugged into the car? And where are you guys mounting yours? Or are you?
 

·
Premium Member
Joined
·
5,356 Posts
Mine wasnt hot.....I believe there is a pix in the ole blue thread where mine is mounted.
I will look in the morning.....gotta get off this thing now.

But I have a picture you can upload to it for the splash screen that says G6.
Its pretty cool. Ill post the link to that in the morning too......Im falling asleep at the keyboard......uuuhggggggggggggggggg
 

·
Pushing Overload
Joined
·
88 Posts
Discussion Starter · #10 ·
I'll look through and find it. Man, hope nothing is wrong with mine. Seems to work ok. Just hotter than I'd think it should be. It got me running 0-60 in 7.7 seconds. I only use it once getting on a highway ramp. That was not a straight run so I'm thinking normal is going to be probably 7.3 or so. I'll find out this morning before I start work.
 

·
Premium Member
Joined
·
5,356 Posts




It looks better on the dashhawk splash screen. lol

Some other mounting ideas here: Clicky here
 

·
Pushing Overload
Joined
·
88 Posts
Discussion Starter · #13 ·
Ok....Well, got my ECM installed. Car starts right up. I've got the coupe and frameless window. Now it won't roll up on it's own. Got the infamous engine code thrown. Went to do the crank relearn and the DashHawk won't do anything. Maybe since I uploaded my profile to it before? All it does when you click on performance tests....or anything else it just shows the current screen.. temps and such. You can get back to the main menu but pushing on anything just leaves you at the screen with current readings. So, I can't even get to the case relearn part.

On a good note....There is a pretty good noticeable power increase. I guess I'll leave it in until I hear from Lamps or someone. I think Chris is at Sema still.
 

·
Pushing Overload
Joined
·
88 Posts
Discussion Starter · #14 · (Edited)
Well this is just great. Put my old ECM back in and guess what. My windows won't roll back up all the way now. They roll down the inch or whatever it is and when shutting the door just stay down now. Now what? A dealership?

Edit....Ok, well I drove back up here to the office 'cuz I thought I left my cell here. When I got out and shut the door the window all of a sudden rolled up????? WTF?
 

·
Breaks Stuff
Joined
·
224 Posts
I'm back, you disconnected the battery right? If not my guess is its throwing a BCM code and affecting your window operation. You should be able to put the new set in and connect the battery and be good to go bestides the crank relearn.
 

·
Pushing Overload
Joined
·
88 Posts
Discussion Starter · #16 ·
Well, disconnected the negative but yep. Welcome back btw....Anyway, a couple hours later after putting the orginal back in they just started working??? There were no codes showing up on the dashhawk after I put the original back in but the windows still were doing that until mysteriously they just started working. Would saving the profile to my dashhawk before cause this with a new ecm / tcm? If so, maybe I could set it back to default and then try this again. Kind of worried about the window thing though.
 

·
Breaks Stuff
Joined
·
224 Posts
Nah you should be fine, the window module just probably had to resync :)
 

·
Pushing Overload
Joined
·
88 Posts
Discussion Starter · #18 ·
Oh, awesome! I was hoping you'd tell me something like that. lol I might have to wait 'til tomorrow to try again, looks like rain... Thanks man!
 

·
Premium Member
Joined
·
5,356 Posts
CHRIS FTW!!! He beat me to it....(like Im some expert! lol)
 

·
Pushing Overload
Joined
·
88 Posts
Discussion Starter · #20 ·
Well, I reinstalled the ECM again and I can't get the case relearn done with the dashhawk. Still throwing the nasty check engine code. Tried it 4x with the instructions that Lamp posted. Temp was fine, set brake, held brake down hard, very very hard. It runs through like it's working but nope.

Any ideas?
 
1 - 20 of 40 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top