Pontiac G6 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hey Guys,

I just bought my 2009 Pontiac GXP (new) December 31st, really enjoying it. There is this weird thing going on with the brake pedal however. Ever since I had it, whenever I brake I feel clicking noises (don't hear the clicking, but rather feel it) while pushing down on the pedal. This only occurs when going at lower speeds, I do not feel pulsing (therefore shouldn't be a rotor issue). While going at higher speeds, (around 30 mph or higher) and braking it does not do it. Also, if I push the pedal down far enough I hear a rubbing noise coming from somewhere around the brake pedal (can also feel it rubbing). I figured it could just be the brakes wearing in when I bought it, etc but it is still doing it. My girlfriend's sister bought a G6 GT the day before me, and I just drove it today and it does not do either of these things. Anyone else have a similar problem to this and know what needs to be done to fix these issues. I don't see the rubbing being related to the clicking feeling that I feel while pressing down on the brake pedal going at low speeds.

Thanks
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #2 ·
I should also note that I only "feel" the clicking while pressing down on the brake pedal, and I do not feel the clicking when I keep the pedal at the same position/spot while being pressed down. It is multiple clicks, obviously the number of clicks vary on how far the pedal is pressed down. The clicking noise is not heard, but rather felt. It only does this at low speeds, not at high speeds. Also, the rubbing noise (which CAN be heard and sounds like it is coming from inside the cabin) happens around after I press the brake about 2/3 (roughly) of the way down. Any help would EXTREMELY be appreciated. I have already had this car to the dealer once to get the sunroof trim/molding replaced because it was bent. I am just nervous with these two issues because I fear the brake pedal may possibly stick or the brakes may fail. If someone could let me know what the possible issue may be I'd appreciate it, I don't want the dealer ripping apart a brand new car. Hopefully this will help with the initial post.

Thanks
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top