Pontiac G6 Forum banner

1 - 10 of 10 Posts

·
Automotive Technician
Joined
·
5 Posts
Discussion Starter #1
Hello. I am having an issue with my hardtop 2009 Pontiac G6 GT with the 3.9L engine. I have never worked with hardtops in my career, so this is all new to me. But the issue I have is when I press the button to retract the hardtop, the motor can be heard(unless I am playing music), then you can hear the locks releasing. The trunk pops up slightly, about 2-4 centimeters or so, the motor shuts off, and the roof moves slowly leaving a gap, then the retraction slows and stops. nothing else happens if the button is held longer. I just bought this car from my work at another child dealership. If anyone can lead me in a direction to fix this, please don't hold back. Thank you.

P.S. I am new here.
 

·
Registered
Joined
·
367 Posts
Welcome to the club. Couple of thoughts.
Sensor issue - there are lots of sensors / micro switches for the roof operation. If one of them is reading incorrectly the movement will stop.
Weak / leaking hydraulics. Check the fluid level on the hydraulic pump. If it is too low you will run out of fluid to move the top. I would also guess that if it is low you have a leak. Mine had similar symptoms when one of the main lift hydraulic cylinders was going bad. The roof operation would start as usual. Top latch release, trunk reverse open and then when it came time to retract the top everything stops. If I remember correctly, if I waited a few minutes and tried to retract the top again (from the same position without closing it again) the motor would retry but stop again. With extra helpers (please have them be careful not to get limbs trapped) to lift the top, I could run the motor and guide the top up to just beyond the mid way point and let it drop into the trunk. This was a bigger clue that it was hydraulic rather than sensor related. I had both of the main lift rams repaired by top hydraulics and it has been fine since. If it were sensor related I doubt you could get the cycle to continue / complete even with people to support the top. I was able to do the same in reverse to close the roof and then remove the hydraulic rams for repair, keeping the top closed whilst I waited for the parts to come back.

If you do get the top down, do yourself a favour and remove the plastic covers by the rear window trim to front seat belt so that you can get to the clips on the hydraulic ram more easily. I did not see a way to remove it with the top closed.

Hope this helps and good luck with the fix.
 

·
Automotive Technician
Joined
·
5 Posts
Discussion Starter #3
Welcome to the club. Couple of thoughts.
Sensor issue - there are lots of sensors / micro switches for the roof operation. If one of them is reading incorrectly the movement will stop.
Weak / leaking hydraulics. Check the fluid level on the hydraulic pump. If it is too low you will run out of fluid to move the top. I would also guess that if it is low you have a leak. Mine had similar symptoms when one of the main lift hydraulic cylinders was going bad. The roof operation would start as usual. Top latch release, trunk reverse open and then when it came time to retract the top everything stops. If I remember correctly, if I waited a few minutes and tried to retract the top again (from the same position without closing it again) the motor would retry but stop again. With extra helpers (please have them be careful not to get limbs trapped) to lift the top, I could run the motor and guide the top up to just beyond the mid way point and let it drop into the trunk. This was a bigger clue that it was hydraulic rather than sensor related. I had both of the main lift rams repaired by top hydraulics and it has been fine since. If it were sensor related I doubt you could get the cycle to continue / complete even with people to support the top. I was able to do the same in reverse to close the roof and then remove the hydraulic rams for repair, keeping the top closed whilst I waited for the parts to come back.

If you do get the top down, do yourself a favour and remove the plastic covers by the rear window trim to front seat belt so that you can get to the clips on the hydraulic ram more easily. I did not see a way to remove it with the top closed.

Hope this helps and good luck with the fix.
Hey Boomer. So yesterday I managed to get some free time at the shop I work and did some really in-depth diagnosing. I found a persistent code: B366B for the left front Decklid Latched switch. I might take it to my local "Pontiac" dealer later today since it is 5:26 AM right now. They would have the parts to fix it there more than mine would.
 

·
Registered
Joined
·
74 Posts
I haven't been here very long and don't have a fraction of the experience that boomer and others here have with top issues. But, I intend to keep soaking up their knowledge for future use. Good luck with your troubleshooting and good call on the scanner messages. Hope your local dealer is useful.

Mark
 

·
Registered
Joined
·
367 Posts
Nice one. Not everyone has access to comprehensive scan tools. Based on your finding you might want to look at the wiring. A few of the convertible owners on here have noticed cracks or breaks in the wiring, especially near hinged areas that get more stressed through motion.

Hope you get it sorted
 

·
Automotive Technician
Joined
·
5 Posts
Discussion Starter #6
So I do have an update. I managed to get the top to go down by forcing the trunk to go up. It seems the hydraulic piston cannot move it without external force when moving up, but it can pull it down with no hesitation. Should I replace that cylinder? I think it's the one in the center of the lid latch if that's the only one on the decklid. If there are multiple that I cannot see, could be those. But the roof retracts excellent after the decklid is opened. I do not have any leaks as far as I know either. Fluid levels have barely dropped.
 

·
Registered
Joined
·
367 Posts
Sounds like you are close to an answer. I would probably ask "how much force". Are you yanking it free of the locking clamps or just assisting ans supporting the motion. If you are having to yank it out then it may be the locking clamp hydraulics that are not fully releasing. I would add that mine has always had an audible "pop" as the trunk lid first moves up, as if the clamps were a little tight. (not wanting to to confuse, but from another thread I have aftermarket gas struts to hold the trunk open in the normal position and it may be that these are slightly the wrong size causing a closure and alignment issue - but mine still works so I am OK with it for now. More details on that here)

Hopefully you can decide what is likely for yourself as you seem to be experienced with cars in general. Also worth noting that I doubt you can just replace the hydraulics as they are no longer manufactured as far as I am aware. Best bets are likely to be tophydraulics.com for reconditioning, ebay or a pick n pull / car breakers for a used part.
 

·
Registered
Joined
·
60 Posts
If you have a weak cylinder that leaks internally it will not have the push or pull to contact the sensor to complete the fold cycle. In this case the GM Tech II will read faulty sensor but in reality its the cylinder.
I took mine to a seasoned mechanic who told me the diagnostics written for these tops was very poor and figured out my issue, which was one of the cylinders.
You can get them rebuilt here: https://www.tophydraulics.com/78-pontiac
 

·
Registered
Joined
·
168 Posts
Update coming soon

The courier dropped off a new set this morning. I will try to get them installed tomorrow and provide an update.
 

·
Automotive Technician
Joined
·
5 Posts
Discussion Starter #10
Sounds like you are close to an answer. I would probably ask "how much force". Are you yanking it free of the locking clamps or just assisting ans supporting the motion. If you are having to yank it out then it may be the locking clamp hydraulics that are not fully releasing. I would add that mine has always had an audible "pop" as the trunk lid first moves up, as if the clamps were a little tight. (not wanting to to confuse, but from another thread I have aftermarket gas struts to hold the trunk open in the normal position and it may be that these are slightly the wrong size causing a closure and alignment issue - but mine still works so I am OK with it for now. More details on that here)

Hopefully you can decide what is likely for yourself as you seem to be experienced with cars in general. Also worth noting that I doubt you can just replace the hydraulics as they are no longer manufactured as far as I am aware. Best bets are likely to be tophydraulics.com for reconditioning, ebay or a pick n pull / car breakers for a used part.
It cannot go up on its own, but can go down fine. The force part is usually wiggling it side to side while moving the bottom lip where you open it normally in a few directions until the hinge loosens up enough on the pivot point to open all the way. I don't know if something is sticking in there, but I will soon lubricate all that a bit more.
 
1 - 10 of 10 Posts
Top