Pontiac G6 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Had the g6 for some time now. Already replaced both pass and drive headlight harnesses for low beam. Today I noticed lights were dim. I first pulled the driver side main connector. The pass went out, check all connectors good, bulbs good etc. Pulled passenger side, same thing all bulbs good, connectors good, driver stays light when unplugged. Drivers side good at this point, hi/low turn. I put the bulbs back in one by one and the second I put the high beam bulb in the connector, all four high and low bulbs light up very dimly, pull the bulb, only the drivers low beam lights, normal brightness. Click the high beams on, only driver high and low beams. Turn signal is completely out on the passenger side no matter what bulbs are in or out. Do not think its a short, leaning more towards the malfunction switch, already replace it about 2 years ago.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Solved!!

Took a better look at everything today and noticed a little corrosion on the main connector from the vehicle to the headlight assembly. Not bad but figured ok try to clean it, picked up the fancy electrical cleaner and cleaned it really good, let it dry, then tested. My turn signal came back on, kept at it and couldn't get another light to come on. Decided just to scrap the harness. Used quick disconnects and heat shrinked everything. Bam, good to go. Would have like to use a 5 pin connect and solider it in, but couldn't find one quickly to get me back on the road. Hope this helps someone out there.
 
1 - 3 of 3 Posts
Top