Pontiac G6 Forum banner
1 - 16 of 16 Posts

· Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
The cruise control is used often by my wife on the Hwy, it was working fine this morning, but on the way home she could NOT get it to work at all. The green dash light indicating that cruise is "on" doesn't even come on.......

Other then checking the fuses, is there ANY other COMMON problems that would cause the cruise too not work.....

Thankx.
 

· Registered
Joined
·
911 Posts
there was a recall on certain 6's so check that. if your g6 is not covered by the recall then it is the brake lamp switch. other problems she should occur are constant running exterior brake lamps and trouble shifting out of park (if this happens push the brake pedal in very VERY far and it will shift). I just had all these problems plus the cruise control issue and they were all linked to a POS Brake Lamp Switch.
 

· Proud G6 Owner
Joined
·
18 Posts
there was a recall on certain 6's so check that. if your g6 is not covered by the recall then it is the brake lamp switch. other problems she should occur are constant running exterior brake lamps and trouble shifting out of park (if this happens push the brake pedal in very VERY far and it will shift). I just had all these problems plus the cruise control issue and they were all linked to a POS Brake Lamp Switch.

Hmm interesting, I'm occassionally having the same issue with my car thinking it was Torque Lock. However, everytime I stop my car, I engage the parking brake and shift into park like you're supposed to, only for it not to shift out of park.

The brake lights at the rear would on and only when they shut off am I finally able to shift out of park.

Plus as you mentioned, the cruise control would sometimes cut out as I'm driving and would only turn back on once my vehicle comes to a complete stop.

My co-worker who was following behind me told me that while I was driving, my brake lights would continuously be on.

I have a 2006 Pontiac G6 GT, so would all this be a reult of the POS Brake lamp switch as well?
 

· Registered
Joined
·
3 Posts
there was a recall on certain 6's so check that. if your g6 is not covered by the recall then it is the brake lamp switch. other problems she should occur are constant running exterior brake lamps and trouble shifting out of park (if this happens push the brake pedal in very VERY far and it will shift). I just had all these problems plus the cruise control issue and they were all linked to a POS Brake Lamp Switch.
This is totally happening with my 2009 G6 (4 cyl). The cruise has been working intermittently for a few weeks now, and the other night when following my wife home I noticed the brake lights looked stuck on. Anyone know where I can get this part? I looked at OReilly and AutoZone, but they only sell universal brake light switches.
 

· Registered
Joined
·
15 Posts
I was not receiving any codes but had issues with cruise, power locks and remote start. It was imtermittent problem that made it hard to diagnose. Check to make sure everything else is working properly. I discovered that the auto door locks didn't lock when I moved the shifter into drive and didn't open when moved back to park. The cruise did not work, the remote start wouldn't work and the transmission did not shift smoothly. After 3 trips to the dealer they found a (TSB) technical service bulletin that told them to reflash the (ECM) computer. Dealer completed this last week and issue was resolved.
 

· Registered
Joined
·
1 Posts
Cruise Control/Brake Light Problem

I am having the same problem with my 2008 G6. I first noticed this a couple years ago when I was driving and the cruise control all of a sudden switched off. This kept happening intermittently for several day then a co-worker told me that I was riding my brakes. I took it back to the dealer and they said that they could not diagnose the problem unless it was currently occurring. This went on for about a month and many trips back to the dealer. Finally I took the technician out and it happened to him. They did something and it went away. A year later it came back. I went through the same BS about not being able to diagnose it unless it was currently occurring. They finally got it and fixed it. Here we are about a year later and I am having the same problem and the same BS with The dealer. Even though it is the same problem, they won't even look at it unless the problem is occurring.

Has anyone had this problem and got it resolved? Getting very frustrated. The dealer has been no help and I am afraid the warranty will run out.

PS - Sorry for the long lengthy reply, I needed to vent.
 

· Registered
Joined
·
2,389 Posts
I am having the same problem with my 2008 G6. I first noticed this a couple years ago when I was driving and the cruise control all of a sudden switched off. This kept happening intermittently for several day then a co-worker told me that I was riding my brakes. I took it back to the dealer and they said that they could not diagnose the problem unless it was currently occurring. This went on for about a month and many trips back to the dealer. Finally I took the technician out and it happened to him. They did something and it went away. A year later it came back. I went through the same BS about not being able to diagnose it unless it was currently occurring. They finally got it and fixed it. Here we are about a year later and I am having the same problem and the same BS with The dealer. Even though it is the same problem, they won't even look at it unless the problem is occurring.

Has anyone had this problem and got it resolved? Getting very frustrated. The dealer has been no help and I am afraid the warranty will run out.

PS - Sorry for the long lengthy reply, I needed to vent.
I am really getting pissed off at GM & how they are dealing with this all too common problem on the G6, Saturn Aura & Chevy Malibu. GM is well aware of this issue & how widespread it is. Who would doubt that this is a serious safety issue? Someone is going to get rear-ended & killed eventually. If it were my car, I would take it up with GM customer service directly & let them know that you are aware of how common this is. You can google up their 800 number.
 

· Registered
Joined
·
3 Posts
I am having the same problem with my 2008 G6. I first noticed this a couple years ago when I was driving and the cruise control all of a sudden switched off. This kept happening intermittently for several day then a co-worker told me that I was riding my brakes. I took it back to the dealer and they said that they could not diagnose the problem unless it was currently occurring. This went on for about a month and many trips back to the dealer. Finally I took the technician out and it happened to him. They did something and it went away. A year later it came back. I went through the same BS about not being able to diagnose it unless it was currently occurring. They finally got it and fixed it. Here we are about a year later and I am having the same problem and the same BS with The dealer. Even though it is the same problem, they won't even look at it unless the problem is occurring.

Has anyone had this problem and got it resolved? Getting very frustrated. The dealer has been no help and I am afraid the warranty will run out.

PS - Sorry for the long lengthy reply, I needed to vent.
As noted above, the problem is either a bad brake lamp switch, or the ECM needs to be reflashed. For me, when I notice the cruise won't turn on, I just hit the brakes... and then it usually starts right up--not a fix to the problem, but a functional work-around. But it's definitely a brake-cruise related problem. In essence the car leaves the brakes engaged--hence the lingering tail lights, which in turn prevents the cruise from engaging, because the cruise is designed to turn off when the brakes are pushed. It makes sense.

Let me know if you figure it out with the dealer. Eventually I should probably get the root of the problem fixed--whether it's an ECM issue or the brake lamp control.

-Tom
 

· Registered
Joined
·
2,389 Posts
Here are the various "fixes" I have read that the dealers try to correct this issue:

applying dielectric silicone "grease" to the C1(X1) & C2(X2) BCM connectors
rezeroing the brake pedal position sensor
replacing the brake pedal position sensor
replacing the electronic brake control module
replacing the BCM
I could be leaving something out

Some fixes seem to work for some folks (at least for awhile).
 

· Registered
Joined
·
61 Posts
I can vouch for the dielectric grease application on the BCM connectors. I had the stuck brake light problem (and non-functional cruise) and an application of grease to the connectors solved the problem immediately (and has prevented a reoccurrence for several months now).

As for GM, I'm done with their cars. I enjoyed my G6 the first 4 years but it's failing apart and has required $1200+ in major repairs this year alone. It's only got 87,000 miles and I didn't abuse it, yet it feels like something twice as old now. I have a feeling problems with early G6's will become more and more common as they age, well above the average and more severe than other cars of that era.
 

· Daily appliance driver.
Joined
·
4 Posts
greenman and CharlesP are correct. Try the dialectic grease as it worked on my wifes G6. I actually made a youtube vid for it but I'm on my work pc and can't post it right now. Search "g6 brake light" and you should find it pretty easily.
 

· Registered
Joined
·
2,389 Posts
That's a good video but I would add two things:

-disconnect the ground side of the battery before pulling BCM connectors

-he shows applying dielectric silicone grease to the C1 connector & I would also do the C2 connector above it since you're in there already
 

· Registered
Joined
·
1 Posts
This is totally happening with my 2009 G6 (4 cyl). The cruise has been working intermittently for a few weeks now, and the other night when following my wife home I noticed the brake lights looked stuck on. Anyone know where I can get this part? I looked at OReilly and AutoZone, but they only sell universal brake light switches.
New to the forum but I thought I could offer up some advice on this topic. I have an 09 G6 as well. I work at a parts store (I'm not allowed to say which one against company policy.) However, I have been dealing with the same issues. There are several topics on the forum which cover this subject of brake light/ cruise control issues. There was a service bulletin from GM about the BCM (body control module) building corrosion in the wiring right at the connector. Which can cause the same issues with cruise control and brake lamps not functioning properly. The bulletin stated to apply dielectric grease to the connector. If you have not done that already that should be the first step as it is very simple to do. There is a youtube video with directions. Takes less than ten minutes. Once you complete that step check the funtions of the cruise control and brake lights. After that you can move to the brake light switch. If you have a newer model such as an 2008 or 2009 you will have to have AZ or Oreilly's look it up below a couple years but it is the same one as I have already replaced mine. It is located above the brake pedal like the fellow before had stated. They run about 30 bucks at my store. Hope this will be of some help.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top