Pontiac G6 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 · (Edited)
Just got this car, this is like the 6th time I’ve used the top- maybe 7. Started to put it down today and realized I had a box in back when it stopped. Closed top, took out package, opened top. Get home and start to close top and it stops after top over car and almost shut. Open it and try to close again- same. Look at deck lid, all looks fine, get back in and look up and see the top is not pushing forward enough so rubber pins and patches are sitting behind the cover instead of inside in the cups. What can I do? Supposed to rain tomorrow morning! Update- now motor not running when I push switch!
Hood Vehicle Bicycle part Automotive exterior Rim
 

·
Super Moderator
Joined
·
910 Posts
Is this happening on both sides? It is also not clear whether the box incident could have caused something to be pushed out of alignment. Putting that aside for now, once the pump has been idle for 5-10 mins the hydraulic pressure will drop. This should allow a couple of you to manually lift the top and see if you can get it into the correct position to have it complete the cycle and close. If you can do that and nothing appears misaligned, then most likely you will need to look at your hydraulic fluid level and check round the main hydraulic rams for any leaks. If the driver's side ram is weak or leaking you may not be getting enough push to complete the arc of the roof cycle. I am just thinking through how this might happen and have not personally experienced it. Hope it helps and you can get it fixed.

If you do find a leak or need the rams repaired, take a look at tophydraulics.com - they have successfully rebuilt the rams for a number of convertible owners here.

Whilst you are at it, also check the wiring by the hinges in the trunk. Not specifically related to your problem, but a number of us have had split and broken wires that have later led to sensor issues. You will find a number of threads on this topic if you search.
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #3 ·
Both sides…it’s like the top drops too soon. I took to dealer who got it closed. The guy who fixed my top on last one was there. He thinks it’s wiring issue interfering with top sensors. After closed still says top not secured. Have appointment Friday. I rather doubt it’s hydraulics as it worked flawlessly couple days before.
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #5 ·
Your right about that! Gm doesn’t even know what techs have certification for the tops at their own dealerships. Thanks I’ll update when I have answer.
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #6 ·
Apparently I bent the arms. He got them adjusted and said it’s working now. Got there, paid the $500 bill and went to put it down and it was making a lot of noise, so stopped. He came over and as I put it back up…said it is as close as he could get it, but it does go up and down, just noisy going in and out of latch in front. Go ahead and put it down…started making the loud noise again and I stopped and he said keep going…hear something breaking…the wings now are not working. Told me to call next week to get it back in. 😡
 
1 - 6 of 6 Posts
Top