Pontiac G6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
This is my first post on this forum, I have a civic, but my mom has a g6 first gen, when they first rolled off the assembly line, I believe in December of 2005. Her car is now getting to be 3 years old, the engine light has come on and whenever you put the tranny (its an auto) into reverse or drive the engine shakes badly and my brother said it feels like the engine's gonna drop out when you do put it from park to reverse. I'm not a car guru, but I know that engine shaking isn't supposed to happen, and it might be a piston misfiring, but you never know. I know my brother accidentally broke the tie rod because he hit the curb and pushed the hub cap into the tire (and that also caused the tie rod to be shot). He also said that the engine light is now on, after he hit the curb goin around 40mph.

all comments and suggestions are welcome, I also know that there are numerous problems when buying a first gen car, and that the gm vehicles weren't made like they were used to.

my dad owned his 88 grand am until 2007 when he bought my car, and it ran just fine, all it needed was a paint job and the carpet on the roof was coming off (the glue was melting i guess) so it needed to be reglued.
 

·
Registered
Joined
·
7 Posts
This is my first post on this forum, I have a civic, but my mom has a g6 first gen, when they first rolled off the assembly line, I believe in December of 2005. Her car is now getting to be 3 years old, the engine light has come on and whenever you put the tranny (its an auto) into reverse or drive the engine shakes badly and my brother said it feels like the engine's gonna drop out when you do put it from park to reverse. I'm not a car guru, but I know that engine shaking isn't supposed to happen, and it might be a piston misfiring, but you never know. I know my brother accidentally broke the tie rod because he hit the curb and pushed the hub cap into the tire (and that also caused the tie rod to be shot). He also said that the engine light is now on, after he hit the curb goin around 40mph.

all comments and suggestions are welcome, I also know that there are numerous problems when buying a first gen car, and that the gm vehicles weren't made like they were used to.

my dad owned his 88 grand am until 2007 when he bought my car, and it ran just fine, all it needed was a paint job and the carpet on the roof was coming off (the glue was melting i guess) so it needed to be reglued.
Sounds like the engine is just idling very low causing it to shake. Could be as simple has a bad spark plug/wire or a clogged fuel injector. I say do a tune up on it, and run some "sea foam" in the fuel and see how she does... then go from there. What is it idling at when in park, and in drive? Does the rpm's drop when you put it in drive/reverse?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
the tranny needed fluid and something else was up with it too. What do ya'll think of the first gens?? They are pretty good cars, but I still know it won't last as long as the grand am :)
 
1 - 5 of 5 Posts
Top