Pontiac G6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey everyone, Just traded a jeep for a 2005 3.5L G6 last week, I didn't think to check the horn when I test drove it and I got it back and of course the horn doesn't work. There is no relay clicking sound when I hit the horn button. I checked the relay by switching it with the fog light relay and it seemed to work normally. So I'm guessing it's an issue with the switch somewhere.

I had the steering wheel off and looked at the connections and everything seemed normal. I didn't to any extensive testing though. I'm not all that great with electrical work so I didn't want to do much to it.

Basically I'm just wondering how I can check the connections at the horn switch and how I can check the horns/horns themselves. The horns were full of water when I pulled them off the car. They are currently not installed on the car cuz I took them off so it would be easier to get to the connections.

Any help would be appreciated, Thanks in advance.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Wow, I looked the fuse box over and over and never saw the actual horn fuze, I figured there was just the relay which seemed kinda odd but I got it now, it was the fuse. Silly me. Anyway, thanks for the reply.
 

·
Registered
Joined
·
10 Posts
Fuse Not Blown and Relay Clicking??

So today I noticed that my horn isn't working?? Checked the fuse and it was fine. I can also hear the realy clicking when I try and use it? Any ideas??
 
1 - 5 of 5 Posts
Top