Pontiac G6 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Hi guys!!!

Here are the steps I took to replace a faulty front passenger hub bearing.

First of all, you will need the following.

13mm socket
14mm socket
17mm socket
36mm deep socket

3 jaw puller (to remove the hub bearing from the axle)
1/2 inch torque wrench that goes up to 160 ft/pounds
U joint extension
Short and medium socket extensions
1/2 breaker bar
New Hub bearing




After safely raising the car and removing the tire, spray some wd-40 or equivalent on the axle threads and nut. This is to clean the threads and help loosing up the nut.



Time to remove the axle nut; stick something in the rotor cooling holes to prevent it from rotating COUNTER clockwise. You may think that the parking gear on the tranny could hold the torque but why risk it. I recommend that you use a breaker bar. The nut size is 36mm.

After removing the nut, we can safely remove the caliper, caliper mounting bracket and the rotor. Be sure to prevent the caliper hang from the hose, be sure to secure it with some wire or tie wrap and tuck it out of the way.


Remove the 3 bolts securing the hub bearing to the knuckle. Be EXTREMELY careful not to damage the CV boot when doing this. The bolts are 13mm



After removing the 3 bolts, the brake shield will be loose and you can actually pull the bearing out of the knuckle. DONT HAMMER on the axle, instead work smartly and get a 2 or 3 (preferred) jaw puller. Be sure to add some lubricant to the spines to help the removal. Be sure to disconnect the ABS sensor from the knuckle before removing the bearing!!!!




Clean the knuckle for dirt and brake dust. I even a light coat of grease on the spines and on the mounting surface of the bearing to help in the install. Just a very light coat. If you overdo this, you will have grease all over the inside of the wheel and probably on the rotors. If in doubt, use some light oil.

Now time to install the new one....


Carefully snake the ABS connector thru the knuckle and axle, don’t connect it yet. Align the brake shield with the holes and slide the new hub bearing. Screw the axle nut HAND TIGHT and screw the hub bearing bolts, again, be very careful when doing this!!
Also, notice that the bolts have some coloring to it. DONT REMOVE IT!!!
That is some sort or thread lock and a cool way of knowing which bolt goes.


Don’t torque them yet.
Be sure that the axle is straight and there is no binding, then start torqueing the bolts in steps up to 85 ft/pounds, to prevent binding. I went from 25, 50 and final torque in a criss cross pattern.
DONT TIGHTEN THE AXLE NUT YET!!

Install the brake hardware then and only then you can torque the axle nut, AFTER securing the rotor from rotating CLOCKWISE, again to prevent strain on the tranny. Again, torque in steps. I went from 50 to 100 to 125 to 159 just to be sure.

Reconnect the ABS sensor cable and harness, if you have some dielectric grease, now it’s a good time to add some at the connector seal to prevent moisture and water inside the connector and to ease removal in the future.... just in case.

Do a final torque check on all bolts, put the car in neutral and rotate the axle. Check the CV boots for damage, check the axle for binding and the ABS wire for rubbing. Mount the tire back if all clears ok.

Go and do some test drive!! Enjoy the sound of silence!!!

Total time, from raising the car to test drive 1.5 hours and that includes looking for the puller.

Skill, from 1 to 10, 10 being an expert, I will rate this a 5. If you can change your pads, you can do this.
As for if you purchase or rent the 36mm socket....well, you will need it if you need to work on the CV joint/boot so for 10 bucks I am sticking with it. It also makes an excellent paper weight at the office!!

Feel free to ask questions!!

Hope this helps those with noisy hub bearings!!
 

·
Registered
Joined
·
3 Posts
So, I have a 2005 G6 GT with ABS, but when I went to change my hub assembly there isn't a sensor as part of it? Why is that?
 

·
Moderator Member Thingy
Joined
·
1,330 Posts
No pictures? :(
 

·
Registered
Joined
·
1 Posts
OK I just did this on my front passenger side. I did it pretty much exactly the way you have written down here but now my ABS light, traction control light and the light with the car and the wrench are all on. What made this happen? I installed them correctly as far as I know and the car drives a hundred times better, no noise or anything but why are these lights on now?
 

·
Registered
Joined
·
292 Posts
need to do this hope its as easy as it sounds.
 

·
Registered
Joined
·
292 Posts
Difficulty 5 out of 10

Done and done! It's quite easy to do, except when the hub assembly/bearing is fused to the metal piece it sits in. the jaw puller just pushed the axle out the back of the bearing and compressed the CV joint. I had to use a big hammer and get aggressive with it, also tried to chisel it out a bit. It finally came out in 2 pieces. But now my car is quiet. :cool:

Thanks for the write up!
 

·
Registered
Joined
·
2 Posts
excellent "how-to"!!
it really is as easy as it sounds
but...both bearings and sleeves were very corroded and seized, and took a big hammer and wd-40 and even a propane torch and just pounded the hell out of it until it was loose. then slowly worked them out, cleaned out the opening, slid new ones in, bolted them up, there we go! smooth ride (and no vibrations, sounds, grinding, etc.) thanks!
 

·
Registered
Joined
·
18 Posts
I remember having to do mine and it was a pain to get it off. Didn't have the tools in the vid but I had a hammer and just started going at it. Eventually loosened for me and bang, it was done.
 
1 - 11 of 11 Posts
Top