Pontiac G6 Forum banner

1 - 9 of 9 Posts

·
Registered
2008 G6 GT Sedan
Joined
·
10 Posts
Discussion Starter #1
Hey,
My turn signal flashers work fine when I flip the switch either way, but for some odd reason they make NO "CLICK-CLICK-CLICK" SOUND at all. Could someone do me a favor and actually listen to their turn signal and tell me WHERE the sound is coming from? If it's coming from the base of the turn signal column, I would guess I've got a bad turn signal switch. Apparently they are known to fail. If the sound is coming from a relay somewhere else, it would be a big help for me to narrow my choices down. Thanks in advance; I appreciate any help I can get!

MB
 

·
Registered
Joined
·
252 Posts
The sound isn't coming from the switch. They commonly fail, but if they do the problem is that they won't cancel automatically. Fortunately, the switches are common OEM and aftermarket items.
 

·
Registered
2008 G6 GT Sedan
Joined
·
10 Posts
Discussion Starter #5
Hmm. If it isn't coming directly from the signal switch, could you give me some idea where the "click-click-click" turn signal sound is actually coming from? Is it perhaps coming from the top of the steering column (inside the cover)? Or perhaps it might be coming from the instrument panel fuse block, on the passenger side of the center console? Hopefully, it's not coming from inside the dash! I had a feeling that the switch itself wasn't making the noise, because the whole unit was so small at its base. I really appreciate the help!
 

·
Registered
2008 G6 GT Sedan
Joined
·
10 Posts
Discussion Starter #6
Did some more searching and just found this:
Possibly there is a small speaker on the back side of the gauge cluster? Mine is a 2008 GT.
 

·
Registered
2008 G6 GT Sedan
Joined
·
10 Posts
Discussion Starter #8
Maybe I could get an instrument cluster with a bad speedo or tach, and hopefully the "speaker" inside would still be intact. Then I could switch the functioning one into my own instrument cluster. Other than not having the "click-click-click"sound, it seems to be working fine. Hate to be spending $$$ to change out the entire cluster just for that one thing...
 

·
Registered
2006 G6 GTP F40
Joined
·
78 Posts
Maybe I could get an instrument cluster with a bad speedo or tach, and hopefully the "speaker" inside would still be intact. Then I could switch the functioning one into my own instrument cluster. Other than not having the "click-click-click"sound, it seems to be working fine. Hate to be spending $$$ to change out the entire cluster just for that one thing...
You sure are in love with the click-click. Lol the one on my colorado doesn't work and love it. Lol
 
1 - 9 of 9 Posts
Top