Pontiac G6 Forum banner

1 - 14 of 14 Posts

·
Spence08G6
Joined
·
4 Posts
Discussion Starter #1
Keyless remote stopped working. Replaced battery and checked fuse with a reader, all working properly. Help. I bought this car used 5 days ago :(
 

·
Registered
Joined
·
2,388 Posts
Keyless remote stopped working. Replaced battery and checked fuse with a reader, all working properly. Help. I bought this car used 5 days ago :(
So it worked 5 days ago?
Are all keys non-operational or just some?
Got a second one? Does it work?
 

·
Spence08G6
Joined
·
4 Posts
Discussion Starter #4
It worked for 5 days, then stopped working on Saturday. It hasnt worked for 3 days now. Battery and fuse fine.
 

·
Spence08G6
Joined
·
4 Posts
Discussion Starter #5
Thanks for the response.We are going to take it back to the dealer we have a warranty. Just wanted to see if it might be something simple.It just sucks cause the dealer is a 100 miles away.
 

·
Registered
Joined
·
14 Posts
Mine wan't working great so I changed the battery. Not much of a change. I have to be right next to the car for it to work and it seems like I have to press really hard on the buttons. However the trunk button works no problem. Hmm, now that I'm thinking, maybe the pads in the remote are worn down.
 

·
Registered
Joined
·
2,388 Posts
It worked for 5 days, then stopped working on Saturday. It hasnt worked for 3 days now. Battery and fuse fine.
If none of the buttons now work, then most likely (99% chance) the battery bracket has broken inside. It can be resoldered using normal electrical soldering technique. Repair is a lot cheaper than 200 miles worth of fuel.
 

·
Premium Member
Joined
·
4,232 Posts
The clip for my battery broke free within months of owning the car. After a touch up all is well! You can buy replacement pads for real cheap on ebay.
 

·
Registered
Joined
·
6 Posts
my keyless wasnt working at all, replaced the battery and nothing, cleaned the rubber pad inside and the circuit board. Just like in that video that shows u need a special contact, yadda yadda yadda, i just cut tiny pieces of tin foil out of my cigarrete pack fold em making sure the tin part is in both sides, put em between the rubber pad and the circuit board close the plastic covers and voila!!!! Its working!!!! Try it, instead of the alternative, good luck!
 

·
Spence08G6
Joined
·
4 Posts
Discussion Starter #12
battery clip was broke free from circuit board.So I soldered it back.Works fine now.

It looks like it was never soldered very well to begin with.I imagine they had their setup to solder smd components and wasn't getting the battery clip hot enough to get a decent connection.
 

·
Registered
Joined
·
2,388 Posts
battery clip was broke free from circuit board.So I soldered it back.Works fine now.

It looks like it was never soldered very well to begin with.I imagine they had their setup to solder smd components and wasn't getting the battery clip hot enough to get a decent connection.
All GM remotes seem to suffer the same two issues: broken batt clip & button pad contact wear. Almost like they are designed to fail.
 
1 - 14 of 14 Posts
Top