Pontiac G6 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have 2 different remotes and I have the same problem on both of them, I can use every single other function on both of them except the unlock button. Do you guys have any idea what the problem might be? Is there an option I might have accidently turned off? I know i can turn off remote start and stuff..

thanks

07 g6 coupe by the way
 

·
Registered
Joined
·
2,388 Posts
I have 2 different remotes and I have the same problem on both of them, I can use every single other function on both of them except the unlock button. Do you guys have any idea what the problem might be? Is there an option I might have accidently turned off? I know i can turn off remote start and stuff..

thanks

07 g6 coupe by the way
Do the door lock/unlock switches function normally?

Did both fobs suddenly start this simultaneously (if you have noticed)?

You cannot disable the lock/unlock function with personalization.

It's possible that both fobs have bad button contacts, given their age. That may be a stretch-only you know the details. I wonder if autozone has a generic fob tester yet. Otherwise, the dealer does. Takes one second to see if that button is bad.

So you push it once & nothing happens & twice & still nothing?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Do the door lock/unlock switches function normally?

Did both fobs suddenly start this simultaneously (if you have noticed)?

You cannot disable the lock/unlock function with personalization.

It's possible that both fobs have bad button contacts, given their age. That may be a stretch-only you know the details. I wonder if autozone has a generic fob tester yet. Otherwise, the dealer does. Takes one second to see if that button is bad.

So you push it once & nothing happens & twice & still nothing?
I can lock/unlock normally from inside the car

I haven't noticed if they stopped working at the same time or not, since one I never used

I push it 20 times and nothing happens lol :)

I'll check if autozone has a fob tester. If it is detecting a signal off my button presses then something is broken within the car probably?
 

·
Registered
Joined
·
2,388 Posts
If it is detecting a signal off my button presses then something is broken within the car probably?
Yes.

I have it in my head that Autozone does have a generic fob tester, but I'd call around first. I've seen them as cheap as 20 bucks recently so I bet they do. Autozone is pretty smart about driving traffic into their stores.

Have you installed any aftermarket electronics lately? Sometimes they can put out RF on the same frequency & confuse the remote entry receiver.
 

·
Registered
Joined
·
15 Posts
I had the same problem. The contact on the back of the rubber part was bad. I could see that it was worn more than the others

First I would clean the board and contacter with alcohol.

If that doesn't work, you can buy a new remote off ebay. Either a normal remote or a remote start FOB will work.

Replace your board into the new remote so you don't have to do any reprogramming. You're basically replacing the rubber part.

Should work like new.
 

·
Registered
Joined
·
2,388 Posts
I had the same problem. The contact on the back of the rubber part was bad. I could see that it was worn more than the others

First I would clean the board and contacter with alcohol.

If that doesn't work, you can buy a new remote off ebay. Either a normal remote or a remote start FOB will work.

Replace your board into the new remote so you don't have to do any reprogramming. You're basically replacing the rubber part.

Should work like new.
Or you can just buy a new rubber button pad for about 10 bucks & shipping which ain't too shabby.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
So I opened up my first remote to clean it and the battery and the little metal piece that holds it in place just fell right off. I'm pretty sure I didn't break it just now so my guess is that it has been broken for a while after dropping it on the ground or something. Anyways, I'm guessing this remote is completely ruined now right?

The second one I opened up and cleaned off, everything seems to work better and be more responsive but still no luck, the unlock button does nothing.

Is your guys best guess a problem with the remote or something within the car?
 

·
Registered
Joined
·
2,388 Posts
So I opened up my first remote to clean it and the battery and the little metal piece that holds it in place just fell right off. I'm pretty sure I didn't break it just now so my guess is that it has been broken for a while after dropping it on the ground or something. Anyways, I'm guessing this remote is completely ruined now right?

The second one I opened up and cleaned off, everything seems to work better and be more responsive but still no luck, the unlock button does nothing.

Is your guys best guess a problem with the remote or something within the car?
I think the possibility that it's a fob problem is still worth pursuing as the other possibilities get a bit more expensive.

If you aren't practiced with the use of a soldering iron try to find someone that is. That broken one is probably salvageable.
IIRC, the dealer charges something like $130 + a $50 programming fee for a new one. So it's worth a try.

For the other one, if you have any electrical contact spray cleaner squirt up that circuit board contact area & the rubber pad contact area good & let it dry & try it again.

You have verified that the batteries are outputting at least 3.0 volts right? Brand new batteries often output around 3.3 volts. But since you never complained about short fob range I assumed it wasn't a problem.
 

·
Registered
Joined
·
15 Posts
Yeah, solder that piece back on.

To test the FOB, open it up. Then use one of the buttons that does work over the unlock contactors (two gold fork looking things) on the circuit board.

If it doesn't work, then its not the rubber piece.

If it does work, you need a new rubber.
 

·
Registered
Joined
·
5 Posts
keyless fob not working

I had the same problem with both my remotes and did some searching on internet and found site called keylessfix.com they have a insert that fits inside your fob and will fix the contact problem the cost is $9.99 ea. I bought 2 and both my key fobs work fine now
 
1 - 10 of 10 Posts
Top