Pontiac G6 Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Just putting this out there in case anyone else has a similar problem... for over a year I had a coolant leak, the car never ran hot, I never smelled coolant or saw any on my driveway etc, but my low coolant light was constantly coming on... every time I would have an oil change, about 2 weeks later the light would come on until I topped it up again...

I took the car in at least 3 or 4 times for the same problem and every time they insisted they could not find a leak. This was to the dealership under regular warranty. On the 4th or 5th time they said they found a hose with a leak, replaced the hose, and for a couple of months I had no problem. This would be during 2009....

In January 2010.. all of a sudden the low coolant light started coming on again.. I took it back in, this time to a different dealership as my pontiac dealership had closed. They found a "crack in the radiator" and replaced the "entire radiator"... anyway... a few days later.. same problem... turns out the new radiator also has a crack in it... so they had to get another new radiator and put that in... no problems since and it has been several months...

The car only had 34,503 miles when the radiator was replaced...

Part # Replaced: 15873468 Radiator
Cost: 402.50 Labor/413.52 Parts
Paid by extended warranty company.

Complaint: low coolant warning light stays on

Mechanic notes: pressure test or leakes - radiator leaking at side tank.
 

· Registered
Joined
·
470 Posts
Dang, thanks for letting us all know!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top