Pontiac G6 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Ok, I have a 2007 Pontiac G6 , base model 2.4 liter, I have had 3 broken half shafts on the driver's side , new control arms, both, wheel bearing, both links, and struts,tie rod ends plus a rebuilt and transmission and alignmemt ,What would keep causing my axle to break ? Btw it breaks in the nuckel closest to the transmission ... HELP !!!
 

·
2007 gt retractable
Joined
·
298 Posts
id buy a different brand of axle.is it possible your mechanic is doing something wrong causing the axles to break?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
It is a different brand, new info, pinch bolt on the knuckle/ball joint on the control arm, keeps popping out , that's what broke the axle but what would make it come out, ball joint is new, controll arm, only happens when making a sharp right turn ?
 

·
08 convertible
Joined
·
214 Posts
If this started happening after a new control arm was installed, most likely control arm was installed improperly.
I remember the control arm installation required several things to be installed to torque specs.
 

·
Registered
Joined
·
236 Posts
Flesh this out: ,' pinch bolt on the knuckle/ball joint on the control arm, keeps popping out '
The pinch bolt needs to be aligned correctly to engage the ball joint and retain it. This seems to read that the ball and knuckle are separating, causing the axle to break? If that is the case, the ball joint pinch bolt isn't being installed properly to engage.
Am I reading this correctly?

Sent from my XT1635-01 using Tapatalk
 

·
Registered
Joined
·
14 Posts
The ball joint stud should have a rounded indent on it where the pinch bolt can engage and lock it in place. The pinch bolt should be the correct diameter to match the indent on the ball joint stud as well. Like davez26 said, something's not being installed correctly if it's separating.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
If this started happening after a new control arm was installed, most likely control arm was installed improperly.
I remember the control arm installation required several things to be installed to torque specs.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
After a garage trip, the only that can be found was not the proper bolt on that ball joint and not enough tourqe ... The bolt on it wasn't case hardened and they tourqed it with air tools ....
 

·
08 convertible
Joined
·
214 Posts
Ok, let's cut to the chase here. If the ball joint popped loose, it was installed by an incompetent mechanic and everything else he did is suspect. Take it to a competent mechanic and have him redo all of the torque settings and check everything the first guy did.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
After a garage trip, the only that can be found was not the proper bolt on that ball joint and not enough tourqe ... The bolt on it wasn't case hardened and they
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
If that's the case then I'm the " incompetent" one doing it in my driveway in the snow and and cold in upstate NY , SO as far as that goes , I did the best I could do , I just couldn't get enough tourqe on the the bell joint ..
 
1 - 12 of 12 Posts
Top