Pontiac G6 Forum banner

1 - 9 of 9 Posts

·
Registered
2007 Pontiac G6 sedan
Joined
·
12 Posts
Discussion Starter #1
Recently, once in awhile, if I take a short drive, like to the store, when I come back out to leave I cannot get the shifter out of park for about 5 to 10 minutes. Transmission shifts well, Transmission fluid level is good, nothing seems to be wrong on the surface. I primarily drive this car on short trips. Occasionally to work and always in snow, also. Anyone have thoughts on what the issue could be? Thanks.
 

·
Registered
2007 Pontiac G6 sedan
Joined
·
12 Posts
Discussion Starter #5
I looked up Pontiac G6 recalls and I couldn't find anything relevant. There was a recall involving the transmission and shifter for my year but it doesn't seem to be the same.
 

·
Registered
Joined
·
38 Posts
I looked up Pontiac G6 recalls and I couldn't find anything relevant. There was a recall involving the transmission and shifter for my year but it doesn't seem to be the same.
Sean,

I'm not saying this is your problem, but have you looked at the linkage under the hood that slides forward and backward.
Mine went bad, and the car wouldn't shift at all. The linkage 'popped" off the stud it sits on due to a neoprene washer that holds it on. Maybe your is just out of whack. Take a look. You can buy the replacement bushing kit from bushingfix.com and I believe it is part # 1m1kit. I, however needed my car and found a little trick to temporarily fix the problem. Get a set of faucet washers from your local Lowes, etc. They come in various sizes. There was one in there that fit perfectly. I put a little silicone spray on it, and it's been fine for 3 years. PS: I did order the kit, and it's laying back for an emergencyJust a thought.
 

·
Registered
2007 Pontiac G6 sedan
Joined
·
12 Posts
Discussion Starter #7
Hi Bear52,
Thanks for the info. I will definitely check that out this weekend. Certainly sounds possible. I love my G6, even if is only used once in awhile. I do everything to keep it in top shape. Thanks again and I'll keep you posted on anything I find.
 

·
Registered
Joined
·
38 Posts
Hi Bear52,
Thanks for the info. I will definitely check that out this weekend. Certainly sounds possible. I love my G6, even if is only used once in awhile. I do everything to keep it in top shape. Thanks again and I'll keep you posted on anything I find.
Sean,

Here's a video I found that might help. The linkage is right under the coolant tank. He took his off....I didn't....Also, if you see the little blue bushing on his, this is what I used a faucet washer for (and as I said ordered the real part but my faucet washer is still working for like 3 or more years.
 

·
Registered
2007 Pontiac G6 sedan
Joined
·
12 Posts
Discussion Starter #9
Sean,

Here's a video I found that might help. The linkage is right under the coolant tank. He took his off....I didn't....Also, if you see the little blue bushing on his, this is what I used a faucet washer for (and as I said ordered the real part but my faucet washer is still working for like 3 or more
Bear52,
Thanks. I looked at the linkage. It all looks good. Ever since I started this thread I have not had any more issues with it. Ill take a more in depth look at it this week. Might be something completely simple.
 
1 - 9 of 9 Posts
Top