Pontiac G6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Help!

My 2006 Pontiac G6 GTP Coupe has been "chugging" the past few weeks (on-and-off) ever since I got my oil changed. The gauges on the RPMs go up and down and you can feel the car "chug" along--even at 20 mph!

Now...the Check Engine light just came on. Argg!

A few months ago--it wouldn't start. It had to be jumped and then it ran for my drive into the office. Then I went to shut it off and it wouldn't start again. It was then towed to the dealership to find that it was a battery problem. Then--shortly after that, my roters had to be replaced--at only 20,000 miles.

Has anyone experienced this "chugging" before? I have an appointment tomorrow but to ease my mind--any advice or help would be greatly appreciated! :confused:
 

·
Registered
Joined
·
195 Posts
if the check engine light is on then the dealer will be able to scan the comuter to define the problem ... otherwise i don't think there's anyone who could tell you what the problem is right away ... sounds like an electronic problem
 

·
^I R CUSTOM^
Joined
·
77 Posts
Began after an oil change? That's odd...usually this problem would be attibuted to the comuputer - something is telling it the wrong stuff. There is a sensor somewhere that is telling the computer soemthing it shouldn't be.
 

·
Decepticon Extraordinaire
Joined
·
5,351 Posts
Sometimes these oil guys check your air filter and they unplug or dont put stuff back right. Sounds like you have an intake leak.....possibly. Check your intake and return line. Check your MAF sensor that it is connected good. Go from your throttle body all the way to your filterbox. if thats ok Auto Zone or a dealership or someone with a Dashhawk can look at the code and tell you what it says.

06...Im guessing your outta warranty...?
 
1 - 5 of 5 Posts
Top