Pontiac G6 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello to whoever can help, my son recently got a 2008 G6 V6 a few months back. Everything was running fine and smooth we fixed the transmission lines which was the first issue we've had. I live in New York and my son lives in Massachusetts now he never told me his AC fuse was giving him an issue. He changed it a few times and kept blowing even putting a bigger fuse in and still didn't work. So a "SO CALLED MECHANIC" which i never was told about cause if i was told i would've sent him to a "REAL MECHANIC". This "SO CALLED MECHANIC" said that the reason that the AC fuse kept was that the AC wire was "FRIED" which he convinced my son that they needed to change the entire wiring harness... This "SO CALLED MECHANIC" put a COMPLETELY DIFFERENT wiring harness FROM ANOTHER G6 YEAR UNKNOWN (SMH) but we do know that the wiring harness has extra and different wires then the original wiring harness. But about 10M driving it all gauges went to zero and on dash it re ERROR. How much damage did this "SO CALLED MECHANIC" do to my sons car? Do you think he fried the Computer of the car? or can i just replace the wiring harness with the original size? PLEASE HELP we just got the car and the only thing that was wrong with it was a Transmission leak which we fixed. Thanks in Advance
 

·
08 convertible
Joined
·
328 Posts
It's not a question anyone can answer. Nobody can predict what may happen when somebody puts an unknown wrong harness in your car.
It's unlikely anything got fried but it's possible. You'll have to put the correct harness in the car and troubleshoot from there.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
It's not a question anyone can answer. Nobody can predict what may happen when somebody puts an unknown wrong harness in your car.
It's unlikely anything got fried but it's possible. You'll have to put the correct harness in the car and troubleshoot from there.
Thank you for the response. That's what i plan on doing for him. Should i get a Computer for the car as well or wait and see if the harness is what just it needs? Just like to be prepared if the harness doesn't work.
 

·
08 convertible
Joined
·
328 Posts
It's hard to give advice based on an incomplete 3d hand story. If I understand you correctly, the car did work fine initially and started acting up after "10M". Is that 10 miles, minutes, months? What happened after? Is the car still running? How well? Is it displaying any other abnormal behavior besides the gauges? Are you and your son both knowledgeable enough to work through the various symptoms and figure out what's what from a distance?

I'm not a big fan of throwing stuff at the wall and seeing if it sticks. So personally I wouldn't put another ECM in it until I was certain it's bad. The ECM also has to be programmed to the car's VIN as far as I know.

You also implied that you know a good mechanic at your son's location. Perhaps having that mechanic look at it might be your best bet? Only you can answer that.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Yes the car worked completely fine. I bought it car off of a buddy, all it had was a minor leak in the transmission metal hose under the radiator which i replaced the lines. Son had the car maybe a month or so and then all this happen. but my Son drove it for 10 mins. Car doesn't start now. all this happen due to a AC fuse that kept blowing and that mechanic said that it could've been a rusty wire, which he seen some from what he recalls. i'm trying to get some time off of work to go down there for now im gonna call the mechanic to check it out. I'm just hoping with buying a new wiring harness would just do the job, they aren't cheap.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
I replaced the motor in my 2006 Pontiac g6 and it cranks over but there is no spark
Not sure but since you changed the motor maybe the shifter cable wasn't put back on or never secured. I would check the shifter cable which is located under the hood. My son had an issue like that and he was missing a rubber piece to the cable which held it in place to switch from park to drive and other drives.
 

·
Registered
Joined
·
2 Posts
I replaced the motor in my 2006 Pontiac g6 and it cranks over but there is no spark
Not sure but since you changed the motor maybe the shifter cable wasn't put back on or never secured. I would check the shifter cable which is located under the hood. My son had an issue like that and he was missing a rubber piece to the cable which held it in place to switch from park to drive and other drives.
Thank you I finally found out the problem and fixed it thanks for your help
 
1 - 9 of 9 Posts
Top