Pontiac G6 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
hey guys. i have somewhat of a rough idle when vehicle is stopped and in drive. if i shift to neutral, it's smooth idle. i changed spark plugs, air filter, oil&filter, cleaned the throttle body, cleaned the MAF, ran seafoam through tank and brake booster line, all within the last few months, and i'm still getting same results. i've taken the car to autozone to have them check to see if it shot any codes, nothing.
any suggestions?

thanks,
-u
 

·
Registered
Joined
·
34 Posts
I have a 05 gt and I have the same problem doesn't run bad or anything just a little funny at idle in gear don't know why it's doing it
 

·
Cute female member
Joined
·
11 Posts
OMG I am having this exact same problem!!! I just bought my car feb 18th I changed the sparks twice! I am freaking out something really expensive could be wrong and I am stuck in payments for the next 36 months. I also put fuel system cleaner in a few days ago and put NGK plugs in today and changed plug wires and still no change. If u figure out what this is please let me know.
 

·
Registered
Joined
·
6 Posts
hi i am a mechanic at a chevy dealer and i had the same exact problem. it came down to updating the computer. just take it to the dealer and have them reflash the computer. should only cost around 200 dollars.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
hi i am a mechanic at a chevy dealer and i had the same exact problem. it came down to updating the computer. just take it to the dealer and have them reflash the computer. should only cost around 200 dollars.
damn.... they're going to charge to update it? that sucks... now, two questions....

1. i had the remote start kit installed a few months ago. the car was already "equipped", it just needed a software update. wouldn't that have fixed it?

2. what if i take it in for a software update, and it doesn't fix the prob? :-\

thank you,
-u
 

·
Registered
Joined
·
6 Posts
well they might have might not did the right system just go there and check to see if your up to date but if you are check your fuel pressure and fuel flow. the computer doesnt monitor fuel systems. since you cant change your fuel filter its a problem in these cars. happens all the time. in the computer system there is a thing called fuel trim. if its trending plus trim that means its trying to put more fuel into your engine so that means either a clogged filter or a faulty pump.
 

·
Registered
Joined
·
2,388 Posts
hey guys. i have somewhat of a rough idle when vehicle is stopped and in drive. if i shift to neutral, it's smooth idle. i changed spark plugs, air filter, oil&filter, cleaned the throttle body, cleaned the MAF, ran seafoam through tank and brake booster line, all within the last few months, and i'm still getting same results. i've taken the car to autozone to have them check to see if it shot any codes, nothing.
any suggestions?

thanks,
-u
3.5l, mileage unknown: That can be tough to find without a good scan tool.

Are you getting any pinging under heavy engine load?

Did you replace the spark plug wires or verify their end-to-end resistance is about the same?
 

·
Gpof59
Joined
·
46 Posts
I would start looking for any vacumn leaks, PCV clogged or dirty? Air Filter dirty? You said you replaced the air filter,so that's out. EGR?, If there's too much EGR flow at idle or cruise or at cold weather conditions, this can cause a rough idle. Other possibilities are, loose or broken motor mounts? lack of fuel delivery from pump or bad injector?, or head gasket leak.
 
1 - 12 of 12 Posts
Top