Pontiac G6 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi everybody i'm new to this forum and I have a question. I have an 08 G6 that has been intermittently showing service airbag soon and service tire monitor soon, sometimes together,most of the time separatly after starting the engine. If I shut the engine off and restart it the fault goes away. I tried searching for this issue on here and haven't found anything yet. I did find alot of corrosion on the negative post on the battery and cleaned it but it did not seem to help, any help woun be appreciated.

thanks
 

·
Registered
Joined
·
2,388 Posts
Hi everybody i'm new to this forum and I have a question. I have an 08 G6 that has been intermittently showing service airbag soon and service tire monitor soon, sometimes together,most of the time separatly after starting the engine. If I shut the engine off and restart it the fault goes away. I tried searching for this issue on here and haven't found anything yet. I did find alot of corrosion on the negative post on the battery and cleaned it but it did not seem to help, any help woun be appreciated.

thanks
Odd as it may seem, low system voltage can cause this.

Have the battery charged & load tested. Clean & tighten the battery terminals.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Thanks greenman that's what I was thinking also, the car does have the original battery in it and they usually don't last very long in the Florida heat. I'm going to pull the terminals and clean them really and put it on the charger for a while and see what happens.
 

·
Legend
Joined
·
782 Posts
Not to be off topic. But where at in Florida are you? I'm also in Florida in Daytona beach.

Sent from my Desire HD using AutoGuide.Com Free App
 

·
Registered
Joined
·
22 Posts
does your remotes work? do you have a aftermarket alarm system/remote starter? i bought a 08 g6 that had a aftermarket remote starter and now the receiver for the FOBS, TPMS DO NOT WORK! and sometimes i will get a air bag svc message also. i have removed the aftermarket crap from the car and waiting on my buddy to get his hands on a TECH 2 to reprogram the Receiver
 

·
Registered
Joined
·
1 Posts
From DClink: "Hi everybody i'm new to this forum and I have a question. I have an 08 G6 that has been intermittently showing service airbag...."

I just bought a 2010 G6 a couple of weeks ago and soon after the "service airbags" light came on and does intermittently. Now the dash lights flicker and the engine and/or the fan continue to run even after I put the car in park, engage the hand brake, turn the key to the "off" position, remove the key, and exit the vehicle! No one seems to know why the "service airbags" light comes on, and the car is now in the shop to look at that (again) and to hopefully find out why turning off the car and removing the key will not cause the engine and/or fan to stop running. It's a bit frightening even though it does not happen every time I try to turn off the engine. I have been given a new battery since the old one was dying probably because of the fan issue; I'm not sure.

I'm new to this forum but hope someone can help me with ideas. Does anyone have any ideas? Has this happened to any of you? Thank you for reading my post.
 
1 - 7 of 7 Posts
Top