Pontiac G6 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 05 gt and notice the traction control wasnt working. I pushed the the button and still no trac control or no light on the cluster, i then notice no service vehicle soon, brake, ABS,oil,engine,security light,cruise,battery,seatbelt and second TC light not working at all. i had a engine replaced (at135k:(:mad:)about 6months ago and took it back to see if something was left unconnected but nothing. i also notice that i have to use 2 keys one to open the doors and the other to start the engine. Any suggestions would help.:confused::confused::confused::confused::confused:
 

·
Da.v3
Joined
·
597 Posts
sounds like maybe a fuse or something?

i mean, for half the cluster to work...

does the light just not come on? or does T/C actually not do anything?
 

·
Professional geek
Joined
·
433 Posts
I have a 05 gt and notice the traction control wasnt working. I pushed the the button and still no trac control or no light on the cluster, i then notice no service vehicle soon, brake, ABS,oil,engine,security light,cruise,battery,seatbelt and second TC light not working at all. i had a engine replaced (at135k:(:mad:)about 6months ago and took it back to see if something was left unconnected but nothing. i also notice that i have to use 2 keys one to open the doors and the other to start the engine. Any suggestions would help.:confused::confused::confused::confused::confused:
Your Body Control Module (BCM) is responsible for controlling all the systems that you report are not working. Fixing it could be as simple as disconnecting the battery for at least 30 seconds and reconnecting it. Another common problem is that the connectors on the BCM have a problem with corrosion. There is a Technical Service Bulletin out to fix this problem, which basically says to disconnect the connectors, inspect and clean them as needed, and prior to reattaching them spray them with a chemical that will help prevent future corrosion. Or, your BCM is just plain bad.

~ MattInSoCal
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top