Pontiac G6 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
2008 g6 gt coupe, 3.5L. Ok so this car was wrecked, not that bad. needed a new engine wiring harness because a few wires were cut, and several pinched, replacing was easier than fixing. I also replaced the ecm with one from the same year car. I know it needs flashed, but it still shouldnt be doing whats its doing. Here is what its doing.
connect battery, turn ignition on, gas gauge reads empty, low fuel light is on. I put 5 gallons in, and no change... hm. odometer reads "error" I Try starting it, nothing, i played with the shifter, no luck. I turned the ignition on, jumped the starter relay, the engine cranks, and it gets spark, has correct fuel pressure, but wont run. every fuse and relay is good under the hood and under the dash. every ground is good. Anyone run into anything like this? I hooked my scanner up to it and it says no communication.
 

·
Breaks Stuff
Joined
·
303 Posts
ECM needs to be programmed LOL It's not going to do anything till thats done.
 

·
Breaks Stuff
Joined
·
303 Posts
hmm... I can understand that theory, but It did the EXACT same thing with the stock pcm, which was smashed.
More than likely this is what happened (assuming all your wiring, BCM is still good)

The ECM they sold you probably wasnt out of a G6 it was more than likely out of something else and they crossed it, I've seen this happen before from that but at least with it programmed it would rule that out :)
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #6 ·
Id just like to add, my automatic windows go down when the door opens, but dont go up when it shuts, and with the key on, the traction control light is on... is that normal? I just think something else is wrong here. All grounds good, no cut wires, every fuse is good
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top