Pontiac G6 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2006 3.9 L GTP. I have an issue with diagnosing why my engine is overheating. The cooling fans only cycle on when the air conditioning/defrost is turned on. All the fuses have continuity and I've replaced the thermostat and engine coolant sensor. Also... the temp gauge never exceeds normal operating temperature even when the engine overheats. I know the engine overheating because the coolant is boiling in the reservoir and steam is escaping out the overflow tube. Any ideas why the fans are not cycling properly? I seem to remember hearing about a service bulletin and a computer software ssue.
 

·
Registered
Joined
·
176 Posts
is your cooling system holding the proper system pressure? If not, the coolant will boil at a lower temperature. A coolant mixture of 50% water and 50% ethylene glycol has a boiling point of 223 degrees. A system with 15 psi cap will add 45 degrees for a final boiling point of 268 degrees. It's possible your gauge is correct. - Mark
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
is your cooling system holding the proper system pressure? If not, the coolant will boil at a lower temperature. A coolant mixture of 50% water and 50% ethylene glycol has a boiling point of 223 degrees. A system with 15 psi cap will add 45 degrees for a final boiling point of 268 degrees. It's possible your gauge is correct. - Mark
Yes the system is holding pressure and I'm using the premixed DEX. Why wouldn't the fans engage?
 

·
Registered
Joined
·
330 Posts
The next question, are the relays operating properly? The thread below has details on operation.
I am not sure what speed operation you get with A/C on, but it would be extremely odd to have both low speed relays fail at once.
You can look at the specs on relays and swap them in the block to test.
Do the fans run correctly?
I was having low speed over heat, i noted that the rh would not come on when low speed was called for. The pair would run at high speed. From the way I read it, they should run together, no single operation. I replaced the set. No fun, but it fixed it.
radiator fan not comming on

Sent from my XT1635-01 using Tapatalk
 

·
Registered
Joined
·
329 Posts
Just a guess but it could be a leaking head gasket. The compression of the engine may be pushing coolant out of the engine.
 

·
Registered
06 G6 GT
Joined
·
17 Posts
Just a guess but it could be a leaking head gasket. The compression of the engine may be pushing coolant out of the engine.
I own two G6 sedans, same year. One base model V6 and a GT, same issue with both engines. After diving down the rabbit hole, on both the cars and the gm 3.5L v6 I've decided to rebuild the one with less miles.
 
1 - 7 of 7 Posts
Top