Pontiac G6 Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
2,388 Posts
Discussion Starter #1 (Edited)
The solution to codes P0010, P0011, P0013 & P0014 for a 2.4L engine:

Firstly, these two parts are covered by your 5 yr 100,000 mi powertrain warranty, if it hasn't expired.

Pull off the plastic engine cover. Find the two small cylinders just to the left of the #1 spark plug. Replace them both. They are called intake & exhaust camshaft position (CMP) actuator solenoids (among other names). Autozone should carry the Dormans but I'm not sure they'll have the AC/Delcos (OEM). Just remove the hold-down bolts & pull up the cylinders. Put engine oil on the new o-rings & don't over-torque the bolts. The two are keyed differently (& have different part numbers) so you can't interchange them. Here's a how-to video:

https://www.youtube.com/watch?v=4Dkdd287AKg

Dorman part # 917-216 (exhaust) & 917-215 (intake)
 

·
Premium Member
Joined
·
4,232 Posts
To help illustrate which part it is, here are a couple of pics I snapped.
The parts in question are in the red circle and are labeled...





Torque spec is 89 inch-pounds (just over 7 ft-lbs). So definitely be careful not to over-tighten them as greenman said.
 

·
Registered
Joined
·
10 Posts
sorry I just figured with the limited years of production all the 3.5 would be the same.

I have the 2007 base sport 3.5

Also could the actuators contribute to engine noise, almost sounds like a lifter ticking was think maybe it could because of limited oil flow? I haven't drove the car much but it seems to just do it after it is driven for a little while. FYI I just got the car 3 days ago.
 

·
Registered
Joined
·
2,388 Posts
Discussion Starter #6
sorry I just figured with the limited years of production all the 3.5 would be the same.

I have the 2007 base sport 3.5

Also could the actuators contribute to engine noise, almost sounds like a lifter ticking was think maybe it could because of limited oil flow? I haven't drove the car much but it seems to just do it after it is driven for a little while. FYI I just got the car 3 days ago.
you bought a car with a problem someone else did not want to fix.
 

·
Registered
Joined
·
10 Posts
I got a P0014 code on my 2008 G6 2.4L. I disconnected the plugs on the 2 sensors, started the car with them diconnected, shut it off, plugged them back in, and started it. Code cleared so far....
 

·
Registered
Joined
·
3 Posts
Dorman parts worked great

This fixed my problems also, part numbers perfect ordered gem on amazon with prime got them in 2 says for a total of $50.00... Excellent help thank you all
 

·
Registered
Joined
·
2,388 Posts
Discussion Starter #10
I got a P0014 code on my 2008 G6 2.4L. I disconnected the plugs on the 2 sensors, started the car with them diconnected, shut it off, plugged them back in, and started it. Code cleared so far....
I'll bet the code came back soon enough.
 

·
Registered
Joined
·
7 Posts
I just did this myself. I had the P0010 code and replaced the intake solenoid. The easiest way to get it out is to remove the valve cover as well. Might wanna check your valve cover gasket while you're in there too. Mine was weeping in the corner. Not an overly time consuming job, just kind of a pain to get the valve cover back on.
 

·
Registered
Joined
·
1 Posts
I'm getting the p0010 code intermittently is it definitely the solenoid or is there something else I need to check 09 g6 base 2.4 eco tech thanks
 

·
Premium Member
Joined
·
4,232 Posts
Replacing the solonoids fixed my intermittent P0010 on my 2009 2.4
I replaced both for good measure. If one is failing/failed the other isn't far behind.
 

·
Registered
Joined
·
7 Posts
Much thanks for the info. My G6 had the P0010 code. The dealer fixed it under waranty the 1st time. Now its reapeared again 3 years later.That u tube vid was really helpful.
 

·
Registered
Joined
·
1 Posts
I just had the P0010 code come up, check engine light was on as well as the traction control light. I replaced the intake solenoid but when I drive my car the engine "hops" or"chugs" not sure what the problem is. Any ideas?
 

·
Registered
Joined
·
2 Posts
I am having same issue with my daughters car right now but mechanic says he has already changed those 2. And still giving me those codes.
 
1 - 19 of 19 Posts
Top