Pontiac G6 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
254 Posts
Discussion Starter #1
CEL just came on this morning. Got the codes read at AutoZone. Something to do with camshaft. The man told me it's probably a sensor.

Will this be problematical the linger it goes without fixing? What can I expect to happen with this code? Is it an easy fix?
 

·
ASE expert
Joined
·
75 Posts
A trick I learned a long time ago is put a half a quart of tranny fluid in your engine a half hour before you change it. Drive it around for those 30 minutes. Then change your oil. All the detergents in Automatic Transmission Fluid will clean your crankcase, oil passages, ect... When your new oil is in you will have a hard time seeing it on the dipstick as it will be that clean along with the rest of the inside of the crankcase.
 

·
Registered
Joined
·
254 Posts
Discussion Starter #6
A trick I learned a long time ago is put a half a quart of tranny fluid in your engine a half hour before you change it. Drive it around for those 30 minutes. Then change your oil. All the detergents in Automatic Transmission Fluid will clean your crankcase, oil passages, ect... When your new oil is in you will have a hard time seeing it on the dipstick as it will be that clean along with the rest of the inside of the crankcase.
Wouldn't that add a risk of over filling your tranny fluid? The idea sounds reasonable, just worried that I'd be adding too much fluid. Although half a quart isn't very much haha
 

·
Registered
Joined
·
254 Posts
Discussion Starter #8
So I went to a Take 5 to get my oil done (2,000 miles behind). Service man walks up and tells me that due to the engine ticking that he would have to turn me away due to liability. I agreed and understood but asked if he could check my oil level anyways. I explained to him that I experienced the ticking problem before and it turned out to be because of low oil. He agreed and told me if it was low that he could take me in and add a couple quarts if need be. Dude checks my dipstick, tells me I'm good on oil and recommended me to a "full service" shop.

Later that day I got ahold of a friend who agreed to help me change my oil. Turns out the car was barely holding all of 2 quarts. Changed it out and the ticking went away. Well my CEL is still on, should I take it to a shop and have them erase the code to see if it comes back? He also suggested I clean my valve cover due to the oil buildup.
 
1 - 8 of 8 Posts
Top