Pontiac G6 Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
156 Posts
Discussion Starter #1
ive had this code pop up several times. the plugs and wires are good. ive ran fuel system cleaner thru it many times. idk what my problem could be. does anyone have any ideas? i have an 07 with the 3.5 140k miles.
 

·
Registered
Joined
·
156 Posts
Discussion Starter #3
i replace the plug and wire everytime it comes up. that's the weird thing, it doesn't feel like it has a misfire going on. still runs normal. after putting in a new plug the cel goes away for a couple months then comes back. i guess i could replace the injector and see what happens?
 

·
Professional geek
Joined
·
433 Posts
You may have a worn ring and the plug is fouling. It would make sense given the mileage on your car and the fact that replacing the plug clears the CEL for several months. What does the plug look like when you pull it? Have you performed a compression check?

~ MattInSoCal
 

·
Registered
Joined
·
156 Posts
Discussion Starter #5
the plug looks used but not bad. haven't done a compression test. this may sound crazy but this past week the cel goes off in the mornings when its cooler but comes on on the way home when its hot as hell outside. any thoughts on that?
 

·
Registered
Joined
·
2,388 Posts
the plug looks used but not bad. haven't done a compression test. this may sound crazy but this past week the cel goes off in the mornings when its cooler but comes on on the way home when its hot as hell outside. any thoughts on that?
That's very strange behavior for the MIL. A misfire code generally would not reset nearly that fast. It requires several driving cycles for the ecm to clear it. Anyway, don't assume it's the same code. Always check it. If you don't have one, for 30 bucks or less you can get a code reader for the glovebox. If you are still misfiring on 5, I'd bet money it's a misbehaving injector. You can swap the suspect injector with it's neighbor as a test. You can also put a mechanic's stethoscope (5 bucks) on the injector & hear if it sounds different than it's neighbor. They're pretty loud. It's a crude check but sometimes very effective.
 

·
Registered
Joined
·
156 Posts
Discussion Starter #7
That's very strange behavior for the MIL. A misfire code generally would not reset nearly that fast. It requires several driving cycles for the ecm to clear it. Anyway, don't assume it's the same code. Always check it. If you don't have one, for 30 bucks or less you can get a code reader for the glovebox. If you are still misfiring on 5, I'd bet money it's a misbehaving injector. You can swap the suspect injector with it's neighbor as a test. You can also put a mechanic's stethoscope (5 bucks) on the injector & hear if it sounds different than it's neighbor. They're pretty loud. It's a crude check but sometimes very effective.
i always have it read at the autozone near by. ill look into the injector and see what's going on there. ill keep you posted, thanks!
 

·
Professional geek
Joined
·
433 Posts
the plug looks used but not bad. haven't done a compression test. this may sound crazy but this past week the cel goes off in the mornings when its cooler but comes on on the way home when its hot as hell outside. any thoughts on that?
Doesn't sound so crazy to me. I suspect a bad coil pack for that cylinder. Things expand as they heat up and whatever physical connection that is just barely making it to allow the plug to fire when it's cold gets too flaky when things warm up.

~ MattInSoCal
 

·
Registered
Joined
·
2,388 Posts
Doesn't sound so crazy to me. I suspect a bad coil pack for that cylinder. Things expand as they heat up and whatever physical connection that is just barely making it to allow the plug to fire when it's cold gets too flaky when things warm up.

~ MattInSoCal
Definitely a possibility. But in my experience I've seen many more injectors go bad than coil packs.
 

·
Registered
Joined
·
156 Posts
Discussion Starter #10
ill start with the injector and go from there. anyone know if there's a way to test the coil pack? and would you guys mind taking a look at a previous thread of mine? its in problems and solutions-over heating issues.any ideas if the two could be related?
 

·
Registered
Joined
·
110 Posts

·
Professional geek
Joined
·
433 Posts
Pretty good for a general guide. It doesn't talk about cracked coil packs and carbon tracks causing arcing, both of which I have experienced on a GM DIS-equipped car. But it's still a good general information source.

One thing you can do is swap the #2 and #5 plug wires and see if the problem follows the swap or stays with the same cylinder. #2 and #5 fire at the same time.



Of course, you can't rule out a flaky injector - but those tend to be bad consistently, not varying with temperature.

~ MattInSoCal
 

·
Registered
Joined
·
2,388 Posts
Pretty good for a general guide. It doesn't talk about cracked coil packs and carbon tracks causing arcing, both of which I have experienced on a GM DIS-equipped car. But it's still a good general information source.

One thing you can do is swap the #2 and #5 plug wires and see if the problem follows the swap or stays with the same cylinder. #2 and #5 fire at the same time.



Of course, you can't rule out a flaky injector - but those tend to be bad consistently, not varying with temperature.

~ MattInSoCal
Have to admit it throws me a little curve that the OP claims the prob goes away for "a couple months" post plug/wire replacement. I would of course expect a 302 code after so much time with your analysis though.
 

·
Registered
Joined
·
88 Posts
I kept getting a "Cylinder 3" misfire...or so they were telling me...they replaced wires, plugs, filters all kinds of shit then they came back saying the only possible issue left to fix would be an engine coil of some sort..and if i didnt replace it my engine would eventually melt...in lesser words. the part was apparently 1500...i said **** that.

3 years now and my engine hasnt melted...but i do still get the flashing check engine light shortly after i turn the car on and it is warming up to 225....not sure why
 
1 - 17 of 17 Posts
Top