Pontiac G6 Forum banner
1 - 8 of 8 Posts

· The New Guy
Joined
·
14 Posts
Discussion Starter · #1 ·
Ok abount a month ago my G6 GTP started throwing a P0300 code, since then I have tried numerous thing to fix this problum, I have replaced or had checked:
Spark Plugs - New Bosh Quads
Plug wires - New
Catalytic Converter - Checked
Coil Pack - New

I have also ran some fuel system cleaner through, while the cleaner helped (seafoam) it is still running kinda rough, I know longer get the CEL light or code but at idle is will sound like its missing just a bit. When I accelerate from a stop light the tranny with shift up too quick realize its mistake then shift back down, I have kept my fool in the same place on the gas the whole time and it will even do this at WOT sometimes, this does not seem normal. Also I am getting 16.5 MPG now in the city and 21 on highway, that also does not seem normal.

Does this seem right to anyone elce? Anything I can check on the car, anything I may have missed?

Im going out of my mind!! haha
 

· Varsity Squad
Joined
·
751 Posts
Because it is a random miss and not cylinder specific you did not need to replace the plugs, wires, or coil pack the code would have been cylinder specific if there was an issue there. But depending on mileage it is good maintenance anyways. Did you clean your throttle body or MAF? Was the P0300 the only code? Check for vaccum leaks or a leak around the intake manifold.
 

· Varsity Squad
Joined
·
751 Posts
well check the intake gasket, use throttle body cleaner and spray it around the intake and see it clears up the idle and runs at a little higher rpms. you can also try to hear it sucking air but this is the best way I know.
 

· Registered
Joined
·
1 Posts
Did you ever get this figured out? I know this is a year old but mine just started this the other day. Exactly as you described it missed and shifts at a high rpm, finds it doesn't have the torque and shifts back. It started doing it when I was going 55 on the interstate up a hill; started slowing down flashing CEL and barely made it up the hill. I coasted off the exit and rolled into advanced and the code reader pulled P0300. I made it home after I cleared it seems like it as driving a little better still rough idle but could chug up a hill at least. Now coming home from work today started missing again more P0300 and this time could barely creep up the hill to the house. It actually stalled the motor trying to drive. I shut it off and let it sit 15 with minimum improvement just enough to 4-way it home.

Whats weird is that coming up this hill I kept throwing it in reverse and backing up driveways and rolling down them to get some momentum for the next chuck I would climb before backing into another driveway. Boy, I bet that was something to watch. Anyway the weird part is that in reverse it seemed to be "better". Better than horrible I suppose. Maybe it was just the gear ratio but if I didn't think I would get arrested I was going to drive it home backwards. It's in the driveway now so I am not going to test that theory anymore. Please let me know if you did come to a solution for this problem or if anyone else has two cents please throw it in, I would greatly appreciate it. 2005 G6 3500 V6 175Kmiles
 

· The New Guy
Joined
·
14 Posts
Discussion Starter · #7 ·
My issue was solved, I should have posted I am sorry for that.
My issue was caused by, get this, too much air coming in and confusing the MAF.
Have you recently installed a CAI? Check your air filter and pipeing for a clog. That would be my only help on this.
Mine was fixed with a WAMS tune for my CAI, not an issue ever since.

r3v
 

· Registered
Joined
·
1 Posts
My beautiful 2006 G6 GTP Cobalt Red Coupe was running perfectly until a knocking/ticking noise shut it down in my driveway. 104k miles. Pulls Code P0300. Had to tow it to a mechanic, who told me it was a "knocking rod, engine needs to be replaced." From the answers above, maybe the mechanic got it wrong. Engine starts but wants to stall out. Oil is good. Have to power-brake to move it. Taking the mechanic's word, I listed it on eBay for $950 just to get rid of it. I think now I might have made a mistake. I wish I could save this powerful, head-turning car partly because I added so many cool exterior modifications, like canards, diffusers, etc. Any tips?
 
1 - 8 of 8 Posts
Top