Pontiac G6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My 2007 Pontiac G6 2.4L has been giving codes P0365 and P0366. I replaced both camshaft position sensors and am still getting codes. Symptoms are difficulty starting (including not turning over, not even initiating a start), stopping once running and no RPM indication. The car has 120,000 miles. Replaced catalytic converter under warranty right before 100,000 miles. Replaced both intake and exhaust CMP actuator solenoids around 80,000 miles (re-tested intake solenoid and shows 12 ohms). Had fuel line cleaned by Valvoline 1 month ago. Had battery replaced 1 year ago and recently checked by advance auto parts, acceptable. Light will come on and off at times. Seems to do it first thing in the morning and when engine is cold. Any recommendations?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
any thoughts, ideas, questions are greatly appreciated. still having trouble. Sometimes i will turn the key and the car wont crank. Then i will try again and the car will crank. Seems to get started quicker when i have my gas pedal to the ground but even then it may take a few start attempts to get it started. Sometimes it will start then crap out a second later. I will retry nd that start may be the golden one and things run fine.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
cleaned trhottle body last night, not much difference. changed air filter with a FRAM, i was suspicious of the brand i had prior to this even though it only had like 6k miles on it. Going to clean MAF sensor soon, too. How do you check fuel pump condition?
 
1 - 5 of 5 Posts
Top