Pontiac G6 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2005 G6 and none of the power windows work with the exception of the passenger front (right front) and it only works with the right front switch and not the driver's switch. I saw that member Peters1919 posted this same problem last year but a resolution wasn't posted. I have changed out the driver's side switch assembly but that didn't help. I also checked the fuses and all look good. I checked the accessory voltage coming from the BCM to the driver's side switch (C1) and it measures about 8 Volts when the plug isn't plugged into the switch. As soon as I plug it into the switch, the voltage drops to about 4 Volts. Any help would be greatly appreciated.
 

·
Registered
Joined
·
2,388 Posts
Sounds like a short to ground somewhere. Carefully check the door wiring harness where it flexes during door opening as that is a high probability problem spot.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
You were right Greenman

Sounds like a short to ground somewhere. Carefully check the door wiring harness where it flexes during door opening as that is a high probability problem spot.
Greenman you are the man! The problem is a bad wire in the harness where it bends at the door opening, just as you suggested. I simply moved those wires back and forth and the windows started working. Now I just need to figure out exactly where the bad spot is and fix it. Based on the symptom it is most likely the ground wire but I guess it could be the accessory voltage (positive) as well. It will be straight-forward to fix now that the problem has been identified. Thank you very much for your help. Have a Merry Christmas and Happy New Year!
 

·
Registered
Joined
·
1 Posts
Greenman or Chris, i know this post is dated by some time, but ive recently come across the same problem, which leads me to the same solution. The wires leading from car to door are the cause of my windows to not work (weird how the front pass does) but any who, how did you fix those bent wires? Im not incredibly car savvy but id rather not pay an arm n leg to a mechanic, is there a fix i could do to prevent whatever wires might be exposed, bent, or touching that is causing this problem? any help would be greatly appreciated. thanks
 

·
Registered
Joined
·
1 Posts
i just bought a 2008 g6 that has the same problem and i did a test with a current test and i found out that the fuse box located by the passenger side has two blue wires that are not sending any power to the power control window , so i connected the yellow and the blue together. and it works perfectly.if you need more info send me a e mail and i will send a picture of what it looks like.
 
1 - 7 of 7 Posts
Top