Pontiac G6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
I have a 07 G6 GT and my factory monsoon radio works (etc shows temp, station, all my info) but there is no noise coming from the speakers.
Any help on this matter would be appreciated. Could it be the amplifier, and if so can I use any G6 amplifier or just the one for the 07 model? Thanks in advance.
 

·
Registered
Joined
·
295 Posts
Damon Jenkins,

I’m sorry you are experiencing this issue with the vehicle. Is the volume up? Are you hearing any sound? Are you receiving any error messages?

Please refer to pages 221 through 251 for additional assistance. For your convenience, a digital copy of the manual is available at: http://www.extendedgmwarranty.com/owners-manual/pontiac/2007-Pontiac-G6.pdf

If this issue persists, I recommend consulting with a certified technician for additional assistance. They will be able to offer more information after inspecting the vehicle.

Louis
GM Customer Service
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3 (Edited)
No noise but the head unit works perfectly, so I am sure its the amp. I just want to make sure before I drop the money on the amp. Also does it have to be the amp from the 07 G6 or can it be from any G6? I have the monsoon system that comes in the car.

Also all the dummy things (volume up, etc.) was checked. No sound at all. Thanks in advance.
 

·
05 G6
Joined
·
101 Posts
I have an 05 g6 and it happen to me also, the stupid amp went out so i got a same year monsoon amp used, and like 8 moths later if went out so i got rid of it all and got a double din all new speakers subs and amp and metra dic
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Yea I just bought a used monsoon amp that was the same as the one already in the car, I will let you guys know how long it lasts, thanks for all the help.
 
1 - 5 of 5 Posts
Top