Pontiac G6 Forum banner

1 - 20 of 36 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 2008 G6 GT coupe, with only 1400 miles on it.. After a couple days after the car was bought, at idle the engine randomly hiccups or shakes a little bit every 10 seconds or so. I have owned plenty of brand new cars and I have never encountered this. The engine is usually smooth and hiccup free. Is this a characteristic of the 3.5L or the G6? I really dont want to bother dealing with the damn dealers if this is a normal thing and I'm just being picky. One of those things, take your three day old car in for a leak in the seatbelt pillar and they have it for four days. Not the greatest time, but thats all fixed. haha. Please help!!
 

·
Registered
Joined
·
585 Posts
For the first year, if i put it in neutral, it would idle normal, rev up a little bit, and then go back down. It would rarely go above 1k, and it only did it ever once in a while. It has since stopped doing that, thankfully.
 

·
Registered
Joined
·
51 Posts
My new '08 GT coupe has done this as well, now that I've had it a week.

Not every time, but seemingly every other time or every few times, it's essentially misfiring (or seems to be). Noticed it more in the first few days than now, but still weird and happens. There appears to be a TSB out for this, but I have no idea what it entails if anything.

Service Bulletin Number: PIP4363
Summary: ROUGH ENGINE IDLE, MISFIRE (DTC P0300) OR NOISE FROM ENGINE COMPARTMENT. *NJ

Odd. One day I noticed it more than others and it continued to give an extra little shake during cruise (of course) as well.
 

·
Registered
Joined
·
465 Posts
Mine also has the rough idle quite often on my 3.5 V6. Yes it seems the engine is misfiring or missing. Most other G6s I have seen have very smooth idles but a few did not. I am going to take it to the dealer to have them check it out along with a few other things.
 

·
Lifetime Member
Joined
·
3,269 Posts
I think some of you might believe I'm crazy but have you tried using 93 octane? I normally use 1 tank of 87 and two tanks of 93. Our G6 runs so smoothly its hard to tell its even running. (just a shot in the dark) I hate to hear of you guys having this problem when our 6 runs so nice.

You other members without this problem, what type of fuel do you use?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
As much as I would love to give my baby that nice fuel, I may have to go without eating that day haha. I know this is not suppose to happen. Has anyone taken their G6 to the dealer yet who has had this problem? I am planning on going as soon as I have the time to sit in the dealership for an hour or so before they tell me whats wrong (if any). I'm loving the feedback! Keep it going!
 

·
Registered
Joined
·
47 Posts
If there is a TSB, I would bring it to the dealer. They might just need to update a program.

I've only used 87 octane and never had the engine shake the car. We shouldn't need premium fuel for this car. Sometimes I would mix in a little premium on really cold days, but that's all. Is the engine stalling? Is misfire and engine knock the same thing?
 

·
Registered
Joined
·
51 Posts
As much as I would love to give my baby that nice fuel, I may have to go without eating that day haha. I know this is not suppose to happen. Has anyone taken their G6 to the dealer yet who has had this problem? I am planning on going as soon as I have the time to sit in the dealership for an hour or so before they tell me whats wrong (if any). I'm loving the feedback! Keep it going!
No, and oddly mine seems to have mostly gone away after a week, but still a slight shake at times.

It's going in Wednesday for the roof that's clunking and creaking away with a couple hundred miles, and I'll probably mention this too.
 

·
G6 Fun-Fan
Joined
·
19 Posts
I have taken my G6 to a dealer, and I've been having the same issue. I've been told that this is not a problem. I was told that my car is in top condition and there is nothing to worry about. I wish they would have had a reason for me, but... no dice. Hope this helps!
 

·
Registered
Joined
·
51 Posts
I have taken my G6 to a dealer, and I've been having the same issue. I've been told that this is not a problem. I was told that my car is in top condition and there is nothing to worry about. I wish they would have had a reason for me, but... no dice. Hope this helps!
I have a feeling that's what I'll be told, too, if I mention it. "Well, about every few times, it has this slight shake like it's missing" and they'll not be able to replicate it, and say nada.

It has gotten much less apparent or present after a week+ of having the car, in my case, so weird. I'm more curious--as it seems common--what the possible TSB might say.
 

·
Registered
Joined
·
51 Posts
mine rough idles every now and then also. Not too bad where its misfiring but def. a lil hiccup here and there
Sounds kinda like my week old one.

That said, I had mine in today for a sunroof issue, and just forgot to mention the rough running. It has to go back again, maybe tomorrow if they can anyway, so may still mention it.
 

·
Registered
Joined
·
11 Posts
Mine does this too... It sometimes feels rough, big bumps, small bumps, and it sucks when you have no music playing and you at stop feeling this rumble :(

2006 G6 V6 Base
 

·
Registered
Joined
·
51 Posts
Finally, as even though I'm still just at 750 miles, this shaking and moreso the shaking while running aren't getting any better, I stopped by and made an appointment for tomorrow.

Trying to get my ducks in line as for description. The shake at idle is getting more and more daily, or at least I think it is, and I've had a wobble especially at 40+ while driving on top of a notable shake/wobble while acceleration too.

I should have expected the wobbles with a G6 and especially one with GY Eagles, but I hope I'm one of the lucky ones where it's fixable quickly. We'll see.
 

·
Registered
Joined
·
63 Posts
you, sir, have what is called VVT (variable valve timing)
it is a nice little performance enhancement (like on my 3.9 vvt) that has a similar effect to a ground cam with lope... every couple of seconds or so you'll get a little shudder (you should feel it with a manual through the clutch with motor mount inserts). it's a new addition to the 08 (and i though 07s but not possitive) 3.5 liters. the block is basically a destroked 3.9 that got tuned down slightly. you should be able to find a lot of people on the internet going "my car is shaking at low rpms whats wrong?" with VVT engines...



edit: didnt notice it happened while you were moving... once you're up to mid RPMS (atleast above 1500) you should stop feeling the occasional vibration... at that point i would take it in and make sure they atleast reflash the ECU with the updated version
 

·
Registered
Joined
·
51 Posts
Yeah, although not a nice feeling, I've read again and again that the idle rumble may be normal. I'd still hope not as the '08 GT I drove before quite a bit didn't make a single vibe ever, but if that is how it is, so be it.

The shake while accelerating sometimes and then wobble at 40+ shouldn't be, though. We'll see. It's been in for sunroof creaking & rattling several times and I hate for it to be in again still before even 1k miles, but a wobble is a wobble.
 

·
Lifetime Member
Joined
·
3,269 Posts
you, sir, have what is called VVT (variable valve timing)
it is a nice little performance enhancement (like on my 3.9 vvt) that has a similar effect to a ground cam with lope... every couple of seconds or so you'll get a little shudder (you should feel it with a manual through the clutch with motor mount inserts). it's a new addition to the 08 (and i though 07s but not possitive) 3.5 liters. the block is basically a destroked 3.9 that got tuned down slightly. you should be able to find a lot of people on the internet going "my car is shaking at low rpms whats wrong?" with VVT engines...
:)I'm curious; you seem to be very knowledgeable on the G6. What is your resource?:)
 

·
Registered
Joined
·
51 Posts
Well, no change. I took it in for the shake that feels like misfiring at idle and also the shake and wobble I get while accelerating and especially cruising at 40+ and above.

A few hours later got it back with a report of "no problem" with the idle and they worked on the wobble. SO...no change on the idle thing. As others here, with the Saturn Aura, etc. have found, just need to get used to it. Weird as the exact same feeling was a misfire due to iffy ignition wires and such in my old Fleetwood, but so be it. Same for the shudder on decel around 45 and below. Oh well.
 
1 - 20 of 36 Posts
Top