Pontiac G6 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello everyone. I am woundering if someone would be able to help me or would be able to give me some information. I own a 2006 G6 GT and the rear deforst does not work but the light above the button on the dash will turn on. I look at the fuse in the trunk and it does not appear to be blown. Is there anything else i should look for?
 

·
Registered
Joined
·
2 Posts
Has anyone found a fix for this? I am having the same issue on my 2007 G6 GTP. The button lights up, I hear a click in the back seat like something engaged, but there is no power drain at all on the car and nothing happens. I also checked the trunk fuse and it is fine.

What a stupid thing to break in a car.
 

·
Registered
Joined
·
2 Posts
I ripped out the back side moldings on either side of the back winshield last night and found the cause of my problem, it may also be yours.

On each side of the back windshield there is a connector tab soldered to the window, and on the driver' side mine was cracked off. It kinda looks like a design flaw to me because the plastic molding rides tight against where the soldered defogger tabs are connected and moves a little everytime there is a bump - no doubt the reason it broke off.

Anyway, the fix is easy. I bought a "Permatex Rear Window Defogger Repair Kit" for 12$ and followed the instructions. Now I can see through my rear window again :)
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top