Pontiac G6 Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
I just bought a 2007 G6 GT Sedan. According to the build sheet my dad was pull for me, it has RPO AP3 LOCK CONTROL REMOTE, KEYLESS ENTRY, START. However, when I try to start it the brake lights flash once and that is it. Saw somewhere that I can just bypass the hood latch to get it working. Problem is, the latch has no electrical wiring running to it. Where does the wiring for it run so I can find it and bypass it? Really want the remote start since its currently to in the cold part of the year here in Minnesota.
 

·
Registered
Joined
·
259 Posts
First question...Is the CEL lit up when you drive the car? If so there is a engine fault (and a code(s) that then disables remote start from operating. That problem must be taken care of FIRST. Then also on the Driver Information Center panel scroll thru the MENU pages till you see the REMOTE START and that it is ENABLED.
Good Luck!
 

·
Registered
Joined
·
58 Posts
Discussion Starter #3
CEL is not light up (unless it has a bad bulb) and it is enabled in the DIC. The car was in an accident during it's life so my guess is that they put the wrong latch in it to save some money. I'll pull the coffee reader out on Impreza (it's dead, G6 is replacing it) and double check for a code.

Guess it's still the sensor wasn't bypassed when they fixed the accident damage.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #4
Just double checked, no CELs stored. Remote start was off on the DIC when I bought it, but I turned it on right away.
 

·
Registered
Joined
·
259 Posts
Well, that takes care of the 2 most common remote start problems that many new owners fail to check. ;) We've got freezing rain and snow here right now to go out in my driveway and look to see where the hood switch is located for you, should be the same with my 08 to your 07.
You also are pressing the DOOR LOCK button BEFORE the remote start button, I hope as that is required for RS operation.

Key to run position(not crank) is the bulb check, if CEL comes on then ,,,the bulb is OK and goes out on startup.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #6
Well, that takes care of the 2 most common remote start problems that many new owners fail to check. ;) We've got freezing rain and snow here right now to go out in my driveway and look to see where the hood switch is located for you, should be the same with my 08 to your 07.
You also are pressing the DOOR LOCK button BEFORE the remote start button, I hope as that is required for RS operation.

Key to run position(not crank) is the bulb check, if CEL comes on then ,,,the bulb is OK and goes out on startup.
Yep, pressing the door lock then the RS button (just like my dad's) truck.

I can live without it for now. Just wish the factory speakers weren't so expensive as its missing the right rear and finding a 2 ohm speaker cheaper is impossible.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #7
Found a single 3 conductor work loose, it had a pink, a purple and a black wire. Based on location and length, I'm guessing it's the right one but if rather be sure
 

·
Registered
Joined
·
58 Posts
Discussion Starter #8
If the value is the same, I just need a 2.3kohm resistance. Or if I way to be fancy, use a SPDT pin switch to have the right value for open and closed.

 

·
Registered
Joined
·
58 Posts
Discussion Starter #9
Got a hood latch on the way. Safest way to make sure it works, although also the most expensive.
 

·
Registered
Joined
·
259 Posts
YUP, just got back from a repair visit myself for my TPMS problem and found it is incorporated in the hood latch assy.////Darned GM way of doing things now!
 

·
Registered
Joined
·
58 Posts
Discussion Starter #11
YUP, just got back from a repair visit myself for my TPMS problem and found it is incorporated in the hood latch assy.////Darned GM way of doing things now!
Hell, I'm still trying to figure out if my G6 has TPMS. I'm glad my dad works for a GM parts wholesaler (in a round about way a GM dealership). I got the latch for his price. Otherwise I'd be using a PIN switch to make it work in the two different resistances it needs.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #14
Finally got the latch replaced. I now have working remote start. Just have to run to the parts store and get some clips for the trim piece that goes from the radiator support and the front fascia.

Sent from my OnePlus 7T using Tapatalk
 

·
Registered
Joined
·
259 Posts
Of course, I did it in 5°F weather.
Join the club...Just got done snowblowing out our driveway(did it Sunday morning too) and 2 neighbors, was 3*f when I started this morning with an hours break between each driveway to warm up again. Hit a high of 20*f as i finished...Gotta LOVE winter in the Northeast! I'll probably soon come down with pneumonia tomorrow!
 

·
Registered
Joined
·
58 Posts
Discussion Starter #18
Join the club...Just got done snowblowing out our driveway(did it Sunday morning too) and 2 neighbors, was 3*f when I started this morning with an hours break between each driveway to warm up again. Hit a high of 20*f as i finished...Gotta LOVE winter in the Northeast! I'll probably soon come down with pneumonia tomorrow!
So glad I live in a small HOA and we pay someone to do it.

Sent from my OnePlus 7T using Tapatalk
 

·
Registered
Joined
·
58 Posts
Discussion Starter #20
But WHERE would the WINTER'S FUN be then?... Just more time to "wonder" and play around with things on your G6!...LOL ;)
What's free time? I have a 3 and 5 year old and do IT for a small company.

Sent from my OnePlus 7T using Tapatalk
 
1 - 20 of 20 Posts
Top