Pontiac G6 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello - I have a problem with my 2006 g6 hard top convertible. It began to occur this winter. I noticed one time after I used the remote start that my right tail light behaved as follows:
1. I hit 'lock' on my key fob
2. The lights blinked in recognition
3. I clicked remote start on my key fob and started the car.
4. The lights blinked in recognition
5. I clicked unlock on my key fob
6. The lights linked in recognition BUT the right tail light went out.
7. When I turn the lights on, the light comes on, so it is not a burned out bulb. Sometimes the brake light comes on and stays on.

I have had it in three times now. The last time they replaced the brake pedal adjustment switch and it quit happening for a while, but yesterday the problem started happening again. The service area doesn't know what is the cause either.

As a side note, the last time it happened, the cruise control had stopped working as well

Has anyone heard of any type of problem like this?

Thank you.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Well I got the resolution: The area near the control switch by the right tail light was somehow full of dirt, etc. Weird. They ordered a new wiring harness, and will position the new control switch differently so this will not happen. It's been a horrendous winter in Minnesota, so perhaps it's just a glitch with snowy/salty/icey roads. Should solve the problem. The former cruise control problem was unrelated.
 
1 - 3 of 3 Posts
Top