Pontiac G6 Forum banner

1 - 14 of 14 Posts

·
beeeeeeefy
Joined
·
883 Posts
Discussion Starter #1 (Edited)
rubbing/rattling under the front end

my 05 GT rattles or rubs against something when I accerelate. It just started doing it last night and its not all the time.. its only when i romp on the pedal from a dead stop. I checked the tires to see if they might be rubbing the wheel well for some reason and they werent. i checked under the hood but nothing to the eye that looks bad or different then any other time the hood is up. my crabs is moveable; like up and down, i didnt know if that might be the issue but it just started and ive had my crabs for 2.5 months now...

its definitely from the front end of the car, and only during acceleration, but there is no engine lag, it'll still shit and get so i dont think its the engine or tranny any help would be great?

EDIT: I forgot to mention.. the noise does go away after the RPMS have dropped
 

·
Decepticon Extraordinaire
Joined
·
5,353 Posts
Yeah your fine....its just a connector from your downpipe to the exhaust. It allows it to flex and move some. Yeah I was serious....looks like rust city.

Then again I live in the south....maybe thats normal up there.
 

·
beeeeeeefy
Joined
·
883 Posts
Discussion Starter #8
Yeah your fine....its just a connector from your downpipe to the exhaust. It allows it to flex and move some. Yeah I was serious....looks like rust city.

Then again I live in the south....maybe thats normal up there.
any idea what that'll cost to replace... im going to say that it is normal sense its not garage kept and with the weather we get around here. thanks for your help poon
 

·
Decepticon Extraordinaire
Joined
·
5,353 Posts
Noooooo....you can pick up the part and have someone weld it in.

You dont need the whole thing. A 2.25" flex should be less than $50.
 

·
beeeeeeefy
Joined
·
883 Posts
Discussion Starter #13
Noooooo....you can pick up the part and have someone weld it in.

You dont need the whole thing. A 2.25" flex should be less than $50.
i understand what your saying.. i seen the megan racing for 50 bucks. but that link you sent for the other thread said gmpartsdirect wanted 300+ for it? lol

Edit: re-read. that was including the cat! never mind!

so this megan racing will work if i pick it up, obviously the shop will have to wield it i know that much, but it wouldnt give them any trouble?
 

·
beeeeeeefy
Joined
·
883 Posts
Discussion Starter #14
soo im still having the same issue.. took the car to the mechanics because i thought my flex pipe was leaking, but its not yet, my resonator had a hole in it, so i replaced that, and that didnt take the sound away, so another shop put a bracket on the heat shield and its still making the noise. idk what else it would be....

it almost sounds like my traction control is trying to engage but the T/C light never comes up... but i know it still works because i was trying to move my car in wet grass on a slant and it was spinning the tires and the T/C light came on and you could hear it kicking in.

does anyone have any ideas on what else this might be. the noise goes away after the car is done with the fast/hard acceleration.
 
1 - 14 of 14 Posts
Top