Pontiac G6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
From time to time, my shifter will not release from park into drive/reverse unless I stomp the brake ALL THE WAY to the floor (which in turn causes my break lights to jam). It lasts through a few starts and then will go back to normal break pressure release.

Has anyone experienced this??? If so what was the problem? I have noticed vibrations when breaking lately which I assume are my rotors warping...would this be a possible cause of the lockups? Or is it an electrical issue?

Its becoming a concern because it has been happening more frequently and my '06/53k mi was purchased used and is no longer under warranty.

BTW- I am new to the sight and am very pleased to find out that Advanced Auto Parts carries moderately priced wiper blade replacements. Auto Zone instructed me to go to the dealer and Wal Mart was clueless. Could not believe the price of the blades at the dealer. Glad I checked the sight prior to purchase.
 

·
Registered
Joined
·
1 Posts
I have that same problem to and was wondering if anyone could help me on it. I took it to a deal and they sadi since they cant replicate the probelm they couldnt fix it. I notice when I turn on my car then i press on the brake and sometimes when the brake seems gharder to push on the gear shit locks up and i cant press the button into shift. Is there a way to fix that or when it happens something i can try? i have an '07 G6
 

·
Registered
Joined
·
5 Posts
I hope it is OK to link to another car forum from here, but this probably explains your issue and the solution is pretty simple.

http://www.chevymalibuforum.com/forums/showthread.php?t=3072

A small tube of dielectric grease is probably all you need. Brush some on your C2 connecter (google has images for locating it). I tried scouring but couldnt find the actual GM notice I once had for this. Anyways, I was having this issue with not being able to shift out of park, and my brake lights coming on without touching the break, and this solved it.
 
1 - 5 of 5 Posts
Top