Pontiac G6 Forum banner

1 - 8 of 8 Posts

·
06 G6 2.4L
Joined
·
2 Posts
Discussion Starter #1
Yesterday I installed an amplifier and in process had to remover the stereo to hook up wiring. Everything went find. No broken plastic or broken bones!:)

However, started off to work this AM and noticed the speedometer was reading 75 MPH and I was creeping along about 35 to 40.

What happened? What and where should I begin to look?

I did have to disconnect the battery and got a little spark reconnecting, but thats normal. No smoke or burn smells.

Just simple Amp install

Any help????
 

·
Premium Member
Joined
·
4,232 Posts
Does it say KPH instead of MPH now at the bottom of the speedo as well? (MPH on the left under 0. KPH on the right under 140)

Is the stock stereo still in place? If so just go through the menu until you get to units and change it Imperial instead of metric. I'm fairly certain you're stuck in metric mode.
If you replaced the stereo with an aftermarket stereo then you may need a DIC adapter kit to change those settings or you may just need to reconnect your stock stereo change the setting and hopefully be good.
 

·
06 G6 2.4L
Joined
·
2 Posts
Discussion Starter #3
CruisinG6,
You are correct!
I made the menu change and everything is fine now.
Thank you kindly!

Ps.. Love ur G
 

·
Premium Member
Joined
·
4,232 Posts
Hey no problem! Glad that was the solution!

And thanks, a lot of time and effort has gone into my G6, And not done yet! haha
 

·
Registered
Joined
·
2,388 Posts
Good call CruisinG6. The personalization settings should not be lost though. I wonder what's up with that. Maybe it's a glitch that only involves a certain version of BCMs. I remember that there have been reports of mileage resetting to zero after a battery disconnect in early model G6s.
 

·
Premium Member
Joined
·
4,232 Posts
That's what I thought, that some BCMs must be different, Is there a way to tell which version or type you have? Maybe we should get a thread comparing BCMs and see if can be whittled down to a problematic line of BCMs..

Also to me it sounded like he left the stock head unit in. If that's the case maybe the head unit defaulted to metric when it was re-installed? Which I'd still find a little odd haha
 

·
Premium Member
Joined
·
4,232 Posts
well I guess I could obviously see what the hardware version is, but what could would that info do really? haha But thanks for that info greenman! Good to know!
 
1 - 8 of 8 Posts
Top