Pontiac G6 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
441 Posts
Discussion Starter · #1 ·
I don't know exactly how to describe it but when at idle the car itself will 'sputter' or 'shake' or 'shimmy'. It will only last for half a second or so and then its fine for another couple of minutes. At work I usually sit in the car on lunch and talk w my wife and smoke a cigarette and with it being so cold, I'd run the heat.

Turned off the heat, same thing. Today I noticed when I put the car into reverse it kinda grabbed a bit harder than usual - I have a 2009 with 65,000 miles - this normal and I'm just now noticing it or should there be maintenance on my side? I think a tranny flush is in order but again, not 100% sure.

Thank you in advance,
David
 

·
Registered
Joined
·
114 Posts
Sounds like an idle issue. I don't think it's a huge deal unless your car is dieing. You can get this changed at a mechanic shop. I think it's something to do with how tight the belts are? But wait for someone else more knowledgeable to agree/disagree with me.
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #3 ·
Fantastic. I know I put a lot of miles on my car but its usually the 120 round trip from home to work so I didn't think the tranny would be it (almost always in cruise at 65) - but - stranger things have happened. Think throttle body or MAF or anything? No codes no major issues just a 'omg freak out' person on that stuff haha!

thank you again
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top