Pontiac G6 Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
so here's the thing its kinda hard to describe, when my car is up to temp and only while driving it wants to stall and die when coming to a stop, has new fuel pump, just cleaned fuel injectors, replaced map sensor. Does t have a evap leak, ( that I know of atm) ( no engine light on atm) disconnected it to do the injectors. Also happens when the ac on and off.
 

·
Registered
Joined
·
248 Posts
When were the spark plugs last replaced? And did you check your oil level...The 2.4 with it's VVT is finicky as oil pressure operates the Variable Valve Timing system. Also would be wise to check and clean the inside of the throttle body of PCV oil fume carbon buildup.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Plugs were done a couple months ago, as was oil, throttle was cleaned the other day as well as a new gasket for it, didnt clean out pcv tho, hose is new but the cover has not been cleaned out.
 

·
Registered
Joined
·
248 Posts
Recheck the intake air tube from air cleaner to the throttle body for cracks or openings in it and that it's well secured to prevent any unmetered air leakage.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
That's the thing, I believe it to be all clear but doesn't hurt to check, also it only happens when its up to temp, and when coming to a stop it wants to die I throw it in neutral to keep it alive with the gas peddle, this only started happening when I moved out to Ohio,
 

·
Registered
Joined
·
248 Posts
You said NO CEL light, if you can it would not hurt to get a scanner and check for any codes in the computer anyway. Also most scanners have some live data read capability to show whats going on.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
I do have a scanner, no codes read, been checking live data everything is running smoothly, that I know of been checking the throttle location looks to be in ramge at idle,, but on mine it brings up the a yellow ( ! ) and not a green checkmark, for the system to be clear of all its problems, but the comp hasn't thrown anything up to see what it is
 

·
Registered
Joined
·
248 Posts
Throttle is electrically operated(no cable), gears that move the throttle "butterfly" are prone to wear and cause improper control(even idle). Been a number of threads here for worn out throttle body and only fix is replacement of the unit. That's why so many start out replying to check and clean the throttle body.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Makes sense, would be great if the ecu would pull a code for it tho on the dash, and not have to have the right scan tool. Kinda was my guess I just didn't want it to be, with how expensive they are even tho its a 12 yr old car
 

·
Registered
Joined
·
248 Posts
Take a look on rockauto.com They are very reputable and prices are hard to beat. Yes Ebay and Amazon may have good prices also, but I prefer rockauto.
 

·
Registered
Joined
·
1 Posts
so here's the thing its kinda hard to describe, when my car is up to temp and only while driving it wants to stall and die when coming to a stop, has new fuel pump, just cleaned fuel injectors, replaced map sensor. Does t have a evap leak, ( that I know of atm) ( no engine light on atm) disconnected it to do the injectors. Also happens when the ac on and off.
Go to your local part store and have them check your car with their obd tester
 

·
Registered
2007 Pontiac G6 sedan
Joined
·
7 Posts
so here's the thing its kinda hard to describe, when my car is up to temp and only while driving it wants to stall and die when coming to a stop, has new fuel pump, just cleaned fuel injectors, replaced map sensor. Does t have a evap leak, ( that I know of atm) ( no engine light on atm) disconnected it to do the injectors. Also happens when the ac on and off.
I know this sounds simple but check the battery cables on the battery. If one or both are loose this could cause this. Any accessories drawing power, like the a c, will cause the car to stall at a stop because the loose cable is not drawing in full battery power.
 
1 - 16 of 16 Posts
Top