Pontiac G6 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
We have a 2006 Pontiac G6 GT with the 3.5L. The car always has shifted hard every once in a while, but i noticed a new thing lately.

When accelerating hard....the car revs up...and then proceeds to shift in the next gear; however, right before if shifts, i get a squealing sound like a belt makes a squeal sound, then it shifts.


It doesn't seem to affect the performance; however, it still makes me concerned. That being said, about a month ago, i was changing the oil in the car and put it up on the ramps. AFter i was done, i noticed this rubber piece under the car. I can't find where it would have come from; however, i was wondering if it's part of a motor mount, and when the car shifts hard, the belt is squeeling under tension? Any thoughts from the picture below. Thanks everyone.

 

·
Registered
Joined
·
916 Posts
I just changed my oil LOL but i didnt see that part and the squealing i always thought was the serpentine belt. Ive read many post about others having this with the 3500 But afteri got my engine and transmission tuned it no longer does this so after all this time i believe its the trans slipping when its shifting 1-2
 

·
WHITE G6 GT (:
Joined
·
159 Posts
S**T. If I start having this problem I'm going to be pissed off. Atleast my car is still under warranty and certified. I'll complain and get it fixed. I wouldn't mind having a new transmission! :D

Dillon :cool:
 

·
Registered
Joined
·
64 Posts
I know this is old, but that part isn't from the car. It's from the Rhino Ramps/Plastic Ramps you are using more than likely. See if you are missing a rubber pad underneath the ramp.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top