Pontiac G6 Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
230 Posts
Discussion Starter #1
Hey guys so I have or had an interesting problem.....Some of the lights on my car randomly went out a few months back so I assumed they were burnt out. Or so I thought. To be more specific the LED's behind the snowflake button (AC compressor button) and the rear defrost on the HVAC controls went out as well as the LED behind the passenger side unlock lock button. When I first noticed this I was pissed bc my car is a 2009 and that kind of shit really angers me. Then I noticed my left fog lamp went out. I installed HIDs so I assumed the bulb burnt out. It would work then randomly stop working then work again and finally just didnt come back on so I gave up on it. Another thing that has been weird is my cruise control. It will work and then randomly shut off then randomly work again. So I have been pretty busy never really got around to replacing the fog lamp so I just didnt turn them on for like 2 months. Well the other day I got around to doing a detail on the inside and outside of my car and I realized my fog lamp works perfectly. At about the same time the LED's behind the snowflake button the rear defrost button and the passenger unlock and lock turned back on. So I figured I would try my luck and use my cruise control alot more and would you guess it it works perfectly fine! So all of these issues that were here like 2 months ago randomly disappeared and have stayed gone for over a week now. Its kind of freaking me out IDK what was wrong in the first place. Does anyone have any experiences like this with their 6? or does anyone have any ideas as to why this is happening? My only thought is that its because the weather is nicer now but I cant see how that would have an effect. Thanks
 
1 - 1 of 1 Posts
Top