Pontiac G6 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just purchased a 2006 Pontiac G6 GT with 66k and quite frankly I am wondering what the hell have I gotten myself into. First, after having the car for only 5 days, the power steering failed. Since I purchased an extended warranty from the dealer, they determined that the P/S unit needed to be replaced? OK... That was 5 days ago. Power steering has not failed...yet?? Then, there was/is a problem with the transmission. After the car has been sitting for a while (usually overnight), when I start the car and put it in DRIVE, it does not engage. It's as if I have it in Neutral. I must "gun" it, so to speak, in order to get the car going and then it jerks forward hard. Took it to the mechanic and he said that the linkage just needed to be adjusted. He claims he did just that, but the car still doesn't engage in Drive unless I do the above. The check engine light came on and so once again, I took it to the mechanic and he says that it was a solenoid problem?? UGh!!! Now, I am hearing popping and clicking when I turn and also it feels like there is something wrong with the brakes/rotors. When braking from high speeds, there is some vibration in the steering wheel and it feels as though the engine has a hard time recovering from that hard braking. It almost feels like the brakes have not disengaged if that's possible. I want to take it to AAMCO and have them perform the free multipoint inspection so that I can take a list of things to the mechanic for him to fix. HELP!!
 

·
Moderator Member Thingy
Joined
·
1,330 Posts
For your power steering, it was under a extended warranty bulletin and you should try and get a compensation for that for you paid out of pocket for any of it. We even have a whole forum section dedicated to it at http://www.g6ownersclub.com/forum/forumdisplay.php?f=33

Your brake problem could very well be a rotor warping issue and is easily fixable by replacing the rotors and brakes (do not resurface the rotors). Can you give us the code that your car gives from the CEL? Do you still have a CEL now? If so, then go to your local auto care store like AutoZone or Advance Auto and get them to scan your car.

Take it to AAMCO. They do good work.

Sorry to hear you are having these problems.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thank you. I appreciate that. I will have AAMCO check it out. Is there a forum for transmission problems? Do you know if what I described is common? What is a CEL?
 

·
Premium Member
Joined
·
4,232 Posts
by CEL he means Check Engine Light.

Popping and clicking in the front end could be an axle or end links. But these cars commonly have noisy front ends. It sucks but over larger bumps you hear it easily, If the stereo is off or low of course.

There was a recall about the adjustment of the Shifter cable. It was often a problem where it wouldn't car ALL the way into Park. and you would then not be able to take the key out. That should have been fixed, But considering its a solenoid issue it should be a pretty simple fix.

I would assume the shop you go to would have at least test driven the car before returning it to you.

And yea, checking with AAMCO is a good idea. haha

Good luck!
 

·
RAM AIR!!
Joined
·
266 Posts
My transmission started slipping really bad when I left work 42 miles away from where I live. It was summer time with about 4 differet construction zones you had to stop at along the way. I never knew it was slipping until I had to stop completely and my car was just revving in drive lol. I had to put it into tap-shift to do anything at all. By the time I got home it was really bad, lucky for me I drive those types of cars all the time at where I work lol.
 

·
Registered
Joined
·
2 Posts
transmission help

sorry not sure if doing this right,, but ok,, my transmission would slip from time to time not too much.. then was driving stopped at a stop light when it turned green i gave it gas and nothing at all, i had reverse neutral and another nuetral, my drive was not there, i put it in the slap shift and it worked so i used slap shift for bout 2 days then 1st i would have to give alot of gas, then 2nd same way, by the second daynone of it worked except reverse, now when i was starting in slap once i got to about 35 mph i could put it in d4rive and it worked fine, until i got back down under 35, im sure its bad i know this.. but transmissions dont usually just go out all of a sudden at a stop light ,, do they.. could it be something else maybe
 

·
Registered
Joined
·
2 Posts
transmission help

sorry not sure if doing this right,, but ok,, my transmission would slip from time to time not too much.. then was driving stopped at a stop light when it turned green i gave it gas and nothing at all, i had reverse neutral and another nuetral, my drive was not there, i put it in the slap shift and it worked so i used slap shift for bout 2 days then 1st i would have to give alot of gas, then 2nd same way, by the second daynone of it worked except reverse, now when i was starting in slap once i got to about 35 mph i could put it in d4rive and it worked fine, until i got back down under 35, im sure its bad i know this.. but transmissions dont usually just go out all of a sudden at a stop light ,, do they.. could it be something else maybe
 
1 - 8 of 8 Posts
Top