Pontiac G6 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
hi to all!

i was hoping i might get some friendly input from you about my 2009 G6 GT

i travel quite a bit with this car and it does great. i got the car used. and at 47,000 miles... maybe a little more, the transmission went out. when it did, something popped but the car kept going til i stopped and then it seemed to lock up. i got the transmission replaced under powertrain warranty

i just turned over 80,000 miles and as of last night i began to hear something like a growl thats increases with speed. i havent had any check engine light or anything come on but the noise is becoming more prominent.

any thoughts?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
ok so i was testing this. the sound is constant with the car in motion. i shifted it to neutral, with it didnt change the sound. However, when i turn to the left, the sound appears to increase, and when i turn right it decreases.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Thank you guys for your help. I was rather scared it might be a transmission fault again. Thankfully payday is this weekend. But too bad I don't have another car to shuttle about in :(
 

·
Registered
Joined
·
1 Posts
Hey guys.. So this is my car too and I know gm power train warranty is 5 years or 100,000 miles. We are under both of those so I have two questions

is this a power train fix?
And is my warranty still valid if I've used it once before?

Thanks!
 

·
Registered
Joined
·
32 Posts
Shifting

Hope I'm doing this right... First time... (rookie) lol...
Can any one help? Have 06 GTP convertible, been reading the nightmares some are having with their transmissions, but none are mine. Quick shift(auto), (cold start) 1st to 2nd... 2nd to 1st, 1st will not engage until 15 mph? 1st, 2nd, 3rd... 3rd, 2nd, 1st- works find... most times*! All speeds are 25 mph and under. * Every now and then.. 1,2,3.. 3,2,1.. 1st will not engage till 10 mph, again speed is 25 mph or less. When running the car... 2nd- 1st will engage at 35 mph! Dealer is scratching their head.. they can not get it to do it. Their answer is the trany is not warmed up. Think they just don't have the knowledge.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #13
haha glenn youve got me confused on that shiftung matter.

just wanted to say thanks to those who helped me to figure out that it was a wheel bearing and not a transmission issue
 
1 - 13 of 13 Posts
Top