Pontiac G6 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I have an 07 g6 gtp, 3.6l. Bought it about 5 months ago used at 29k miles. Warranty and everything is still on it, prior owner was a rental company.

When i bought the car everything was fine. Im pretty hard on my car, accel. quickly, stop quickly ect. Then my transmission started acting up. Sometimes when im accelerating the car shifts hard. it doesnt jolt my car or anything but you can definitely hear and feel it. It also sometimes doesnt shift at all until a couple seconds after it revs at 6k rpm. only one time had it not shift at all and i had to let off the gas for it to shift.

When i changed my oil in the car me and buddy both noticed some fluid under my transmission. we wiped it off an sae that it was transmission fluid. Its not dripping on the ground or anything but its still leaking a little bit. Took the car on a road trip and the transmission started acting up more often. checked the trani fluid and the level was fine.

just asking if anyone had some insight on if something is loose in the trani or if its a moer serious issue.
 

·
Registered
Joined
·
36 Posts
if its the 6speed auto,should be a pretty sealed unit.might be coming from a breather on top of trans.probably should get the computer scanned for trans/engine codes...
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
thanks for the info. im going to go to the gm repair shop tomorrow an dsee what the think. ill also ask them if they can scan the computer on the trani and see if they see anything wrong with that.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4
finally sent the car in yesterday. they looked at the trani and didnt find a problem with it. so they scanned the computer and found out that it needed an upgrade. So they put in the new upgrade.

outta town right now so as soon as i pick it up ill see if they fixed the problem.
 

·
Registered
Joined
·
6 Posts
just kinda curious about the outcome on your car. i have a 06 gtp(automatic) and i was having the same hard shifting problem. it shifted hard oneday and that was it. when i put it in drive nothing happens at all. when i use the manual option, first gear studders but two thru four are fine. i'm tryna prepare myself for the worse (a new tranny). any suggestions
 

·
Registered
Joined
·
555 Posts
just kinda curious about the outcome on your car. i have a 06 gtp(automatic) and i was having the same hard shifting problem. it shifted hard oneday and that was it. when i put it in drive nothing happens at all. when i use the manual option, first gear studders but two thru four are fine. i'm tryna prepare myself for the worse (a new tranny). any suggestions
This thread was posted back in 08. Unless this member is still active, he probably wont respond.

As far as your problem, take it to the dealer and have them check it out. Sometimes if your lucky the problem is a tiny part or computer programming and not the tranny itself.
 

·
Premium Member
Joined
·
566 Posts
Usually people join, ask their question, get the advice they needed and leave never to return. A sad but true reality, we'll probably never know what the outcome was.
 
1 - 7 of 7 Posts
Top