Pontiac G6 Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
got a 2006 g6 gtp with the 3.9 its got the automanual trans in it this morning drive stopped working stopped at a stop sign and press the gas and wouldnt go put it in manual and seems to be working fine just not in automatic any idea what could be causing this
 

·
Banned
Joined
·
258 Posts
Go to the dealership and have them check the transmission harness. If thats not it, then try to change out the tranny fluid and filter. If that isnt it, then your transmission is toast. GL
 

·
Moderator Member Thingy
Joined
·
1,330 Posts
Definitely a electrical issue if the tapshift works, but automatic doesn't.

Is the problem still persisting or did it only happen once?
 

·
Registered
Joined
·
9 Posts
Same thing happened to me yesterday, then today the Manual went out, had it towed to dealer, not sure but think they are replacing transmission, repairman said eventhough its sealed can still get dust in there, I questioned?? But all is covered by the 100,000 powertrain warranty. So replace it, my 07 HTC has 44000 miles.
 

·
Registered
Joined
·
9 Posts
Transmission problem.

I have been waiting two weeks for GM to send a transmission for my 2007 HTC G6, 3.9L, had the same problem, covered by 100,000 mile powertrain . The day after my breakdown another G6 HTC was towed to dealer for same problem!!
 

·
Registered
Joined
·
5 Posts
Called them today after about two days of them having it and they said that they are "Overhauling" the transmission. Should be back in my hands by the end of the week. So they say...
 

·
Registered
Joined
·
5 Posts
Adding another update for all of you that care. Car has been at the dealer for a week, they are now rebuilding the transmission for a third time since it leaks now. This will be the last time before I ask for a new transmission.

The lease is up in June, it is definitely going back!!
 

·
Registered
Joined
·
9 Posts
Got my car back from dealership 5 days ago, so far so good, they replaced the transmission and the raditor. Have only put on 60 miles since I got the car back, today while stuck in traffic due to an accident I noticed smoke or steam coming from font of the hood, hopefully that is only because of the new radiotor, the temp did not rise any so hopefully thats it. Another car towed in G6 towed in after mine had the same prob, they replaced the trans and the new trans was bad. I know these trans they put in are rebuilt but isn't there any quality assurance done by GM on this? I am beginning to hate this G6 HTC that looked so dam great when I got it!!! Good luck, at least yours is a lease, I am stuck!!
 

·
Registered
Joined
·
5 Posts
Does anyone have the number for GM? I am looking for a national customer service number? There is some seal that is back ordered indefinitely from GM and my dealer has no answer to when it will be back in stock. Still don't have my car back and it has been over 2 weeks.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top