Pontiac G6 Forum banner
1 - 20 of 30 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
So this is the problem im having with my Automatic Transmission, just recently my transmission has been shifting really hard for each gear and the engine light has also came on too, now sometimes it goes away and the gears shift normally and then it loops again and happens all over again. I cant seem to figure out what the problem is or maybe do I have to bring it to the dealership to get the computer reset or something else causing this problem, has anyone else had this same problem before?
 

· Registered
Joined
·
287 Posts
There is a TSB for that

Bulletin No.: 06-07-30-034

Date: December 20, 2006

TECHNICAL
Subject:
Service Engine Soon (SES) or Check Engine Light On, Harsh Shift, DTCs P0742 and P2761 Set or Just P2764 Set (Replace Automatic Transmission Wiring Harness)

Models:
2006-2007 Buick Allure (Canada), LaCrosse, Lucerne, Rendezvous, Terraza
2006-2007 Chevrolet Impala, Malibu SS, Malibu Maxx SS, Monte Carlo, Uplander
2006-2007 Pontiac Grand Prix, G6 GTP, Montana SV6
2006-2007 Saturn Relay

with 4T65-E Automatic Transmission (RPOs MN7, M15 or M76)

Condition

Some customers may comment on the Service Engine Soon (SES) or Check Engine light being illuminated. Upon investigation, the technician may find DTCs P0742 and P2764 together or just P2761 set as current or in history. Also, the customer may comment on a harsh shift.
http://www.alldatadiy.com/alldata/A...850750/42063452/122648690/126161223/126161224
The tan wire (1) of the Torque Converter Clutch (TCC) Solenoid Valve harness may be incorrectly routed around a metal retaining clip causing a chafe in the wire insulation, resulting in a short to ground. The harsh shift concern is due to the default code causing high line pressure to be commanded.

Correction

If diagnosis indicates a grounded circuit, replace the transmission wiring harness following the published replacement procedure in SI. Be sure to route the tan wire out of the metal clip.

When servicing 2007 vehicles, the metal clip for the temperature sensor connector on the new harness must be removed and discarded prior to installation. Reuse the plastic clip from the old harness.
 

· Registered
Joined
·
6 Posts
Discussion Starter · #3 · (Edited)
Ok thank you, i will look into that, but I actually got the error code from one of the OBD2 Readers and it said the cause was my Air Intake Sensor 1 being on the high level, so the minute i cleared the code the transmission was back to normal, could it be the cold air affecting the sensor to read at a higher level and causing the engine light to come on? Cause i only had my aftermarket intake during the summer not the winter.
 

· Registered
Joined
·
287 Posts
So I brought my car to the dealer and you were right it was the Transmission Wiring Harness they had to replace, cost about 190 bucks to replace but at least its fixed now.
Well, I am glad you got it fixed. I don't understand why they charged you for the repair, it's a TSB so I think that would indicate a manufacturer defect.

Seems like there are many defects with these cars. Luckily I have not had much trouble with mine. It seems like its always stupid things that are giving people the most trouble.

I think I am going to buy a classic car next. Been looking at a 70 LaMans with a 389 and 400 turbo. Not all original but it has upgraded suspension, steering and has been lowered 1" and has 15" thrust wheels. Does not have all the bells and whistles but I know I can put 100k miles on it with no problems.

It looks good and is silly fast.
 

· Registered
Joined
·
1 Posts
I also just recently experienced the hard shifting. The engine light also comes on then off.
I was told the the hard shiting may be a another bad catilic conveter.
A few months ago the engine light came on and noticed when I accelerateed I had very little to no power. Turns out it was a bad catilic converter. Luckly it was covered under the manufacture warrenty. What are the odds of that being the problem?
Please help! not sure what to do.
 

· Moderator Member Thingy
Joined
·
1,369 Posts
TSB are just instructions to dealership techs on how to fix common problems that occur in vehicles.

EDIT: Damn, old thread. Rae, you should go to the dealership for the above TSB posted before.
 

· Registered
Joined
·
16 Posts
does anyone have a picture of where this tan wire is located? the picture I have printed from a tsb isn't clear. it appears to be of a Trans thats is out of the car and so far from the top I cannot locate it. I haven't check underneath teh car since its raining at teh moment but if anyone can direct me I would like to see this wire before I take it in to the shop
 

· Registered
Joined
·
606 Posts
Ok thank you, i will look into that, but I actually got the error code from one of the OBD2 Readers and it said the cause was my Air Intake Sensor 1 being on the high level, so the minute i cleared the code the transmission was back to normal, could it be the cold air affecting the sensor to read at a higher level and causing the engine light to come on? Cause i only had my aftermarket intake during the summer not the winter.
Faulty IAT sensor or wiring will cause hard shift, my 99 Sonoma will to.
 

· Registered
Joined
·
2,389 Posts
does anyone have a picture of where this tan wire is located? the picture I have printed from a tsb isn't clear. it appears to be of a Trans thats is out of the car and so far from the top I cannot locate it. I haven't check underneath teh car since its raining at teh moment but if anyone can direct me I would like to see this wire before I take it in to the shop
Lots of things can cause harsh shifting so if you have that complaint the place to start is having the codes read.

Note that bulletin only applies to the '06-07 GTP with 4T65-E tranny.
 

· Keep it factory baby!
Joined
·
100 Posts
I had to have a cylinoide/valve replaced for hard shifting. When the car would go to ssecond gear it would jump like someone hit me from behind.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

· Registered
Joined
·
9 Posts
if its the 2.4 liter engine check the intake cam sensor. top of valve cover left side intake cam sensor should be gray electrical end if you unplug the two wires (exhaust and intake sensors). front sensor toward front of vehicle should be the one needing replacement
 

· Registered
Joined
·
5 Posts
I have an 06 G6 with the 3.5 v6 RPO MN5 which should be the 4t45 trans.

I am having hard shifts and I live in ohio and today I was driving back home in the rain and the car would basically not shift getting onto the freeway, but at slower speeds it would snap you back in the seat when only barley getting on the gas. The hard shift happened once a few weeks back was also in the rain but I didn't think anything of it until it was non stop on the way home. Once I got off the freeway about 45 minutes later it shifted fine all the way the rest home but was only a few minutes and a handful of shifts. I noticed this thread and TSB on ALLDATADIY and was going to take the day off tomorrow and see if I can find a break in any of the wires in the harness. If anyone out there is seeing this and has any incite on what to do or look for that would be greatly appreciated.
 

· Registered
Joined
·
5 Posts
I would encourage you to take it to someone that can read all the car's codes. In other words, has a proper scan tool.

Do you have that bulletin number you refer to?
I took today off to take my car to my dad's garage and I had a chance to check over the car and hook up to his scan tool and take a test drive. I had two DTC's. P0752 and P1750 both are related to 1-2 Shift Solenoid. I have about 120k on the car and I had trans flush/fill at 80k since I tow two skis with the car in the summer months. The hard shifts/no shifts are spotty at best right now. I am leaning toward dropping the trans and replacing 1-2 SS and maybe even getting a new wiring harness while I am in there. Got a quote from a local dealer at it was 6hr $750 total to do the work. So I would definitely be doing it on my own, but please let me know if anyone has any info that would be helpful in my case.


PS. In my road test the 1-2 SS was working correctly so I cleared codes and it hasn't shown up again yet, but I'm sure it will soon. I also checked the trans fluid level and it was good and the fluid looked good as well.
 

· Registered
Joined
·
9 Posts
I would say check the intake and exhaust cam actuators. I had to replace them on my car as well. Otherwise I've heard problems with the wiring harness and complete tranny tear downs involved but hard shifting mainly in 1st and 2nd was caused by the cam actuators on the top of the valve cover on the left side there are two of them. they just come out with one 10mm bolt and then pull and they will slide out. PN was

12628347 and 12628348 for intake and exhaust. got them through gmpartseast.com they are 33.77 bucks. hope this helps
 

· Registered
Joined
·
2,389 Posts
I took today off to take my car to my dad's garage and I had a chance to check over the car and hook up to his scan tool and take a test drive. I had two DTC's. P0752 and P1750 both are related to 1-2 Shift Solenoid. I have about 120k on the car and I had trans flush/fill at 80k since I tow two skis with the car in the summer months. The hard shifts/no shifts are spotty at best right now. I am leaning toward dropping the trans and replacing 1-2 SS and maybe even getting a new wiring harness while I am in there. Got a quote from a local dealer at it was 6hr $750 total to do the work. So I would definitely be doing it on my own, but please let me know if anyone has any info that would be helpful in my case.


PS. In my road test the 1-2 SS was working correctly so I cleared codes and it hasn't shown up again yet, but I'm sure it will soon. I also checked the trans fluid level and it was good and the fluid looked good as well.
Not sure how I missed this post earlier.

The tranny harness issue does not apply given those dtc's.

I don't do tranny work so I hesitate to give you any advice other than your faulty 1-2 SS valve diagnosis appears correct.
 
1 - 20 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top