Pontiac G6 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My girl friend s 06 GT g6 doesn't move in first I have to shift it manually. Was I get to second I can shift it back intodrive and it works great. She had over filled the fluid and it started doing this I drained it to the correct amount and it didn't help . The she put this cheap 3 dollar trans stop slip from Walmart and the car now doesn't want to shift in manual. The trans is gone I'm afraid .. need advice
 

·
Registered
Joined
·
441 Posts
I am sure opinions on this will vary. If it were mine and I were of the impression that the quality of the fluid and additive were suspect and I lacked evidence for a more serious issue I would try some lower cost items to see if I could revive things. I would add seafoam transtune, shift through all the gears and drive it for a couple of days to see if I could clear out any gunk and get it into the fluid. Drain the transmission, drop the transmission pan and replace the filter (and gasket if it makes sense to do so). Refill it with the proper fluid (Dexron VI). Depending on how bad the original fluid looked and smelt I would consider a second drain and refill to flush out some of the old fluid from the torque converter etc.

Hope you get it fixed and prove to be boyfriend of the year / hero material round valentines day. But please don't be a stupid hero :) Ensure the car is safely supported if you are going to be working under it.
 
1 - 2 of 2 Posts
Top