Pontiac G6 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I had a bad shift solenoid in my 07 G6, so I decided to change the filter and replace both shift solenoids as well as the lock up solenoid and the EPC solenoid. This is a V6 with the 4t45e transmission. After changing the solenoids and filter, I filled the fluid and ran it through the gears while still on jack stands and noticed the wheels were spinning forward regardless of the shifter position and if I brake checked, it did not feel as though the transmission was fully engaged. I had struggled some trying to get the new filter in place, so I removed the pan and found the filter had come loose and was lying in the pan - so I re-installed, ensuring that this time it was properly seated. I replaced the pan and re-filled the fluid with similar results, only this time the tires go in reverse regardless of the gear selector position.... I pulled the pan again and the filter is fine. Any ideas on what to check? I had no slippage or issues prior to changing the solenoids... what have I done???
 

·
Registered
Joined
·
3 Posts
I also have an 06 g6 doing the same thing, had a code of p0751 for 1-2 shift solenoid stuck open, we didnt new filter and solenoid and now all gears are forward. I'll check my filter in the morning. Also mines a gt so it has the manual and were the milage is it shows m1 dont know why but might check yours. Hopefully some on here will help us in the right direction.
 
1 - 4 of 4 Posts
Top