Pontiac G6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
So my girlfriend has been telling me about this weird issue she has when she tries to start her car. It is not very common, maybe once a month I think. I have never been around to witness is till tonight. She turned the key to start the car and it just cranked for a longer than normal period of time and then it turned over for a split second and revved to 1000rpms and just stuttered and then died. It did this 4 times, and on the 5th time I lightly tapped the gas peddle and it started right up as if it wasn't getting fuel or something before. Never seen an issue like this before and was wondering if anyone else has had an issue similar. Car is a 2006 G6 GT 3.5 v6.
 

·
Moderator Member Thingy
Joined
·
1,330 Posts
While my problem wasn't exactly the same, I had a similar problem with my 2006 G6 GT with starting. Cleaning the throttle body does the job mostly. Whereas before it would do it once or twice a week, it now has only done it twice in the past year.

Get some throttle body cleaner from an auto parts store, remove the intake piping, and unscrew the throttle body off. Take a toothbrush/paper tower and go to town on the inside piping and butterfly valve.
 

·
Registered
Joined
·
190 Posts
Once in a great while mine will so something similar. I will turn the key and it will try to start, sounds like its misfiring and then will either finally start or not start at all. I don't know the exact reason why it's does this, but you're not alone with a weird starting issue. It's like the computer is forgetting to send fuel to the motor on startup. BTW, my TB is clean, I already checked that ;)
 

·
Moderator Member Thingy
Joined
·
1,330 Posts
Once in a great while mine will so something similar. I will turn the key and it will try to start, sounds like its misfiring and then will either finally start or not start at all. I don't know the exact reason why it's does this, but you're not alone with a weird starting issue. It's like the computer is forgetting to send fuel to the motor on startup. BTW, my TB is clean, I already checked that ;)
Starting issues could be a number of things. I've heard anywhere from faulty PCM programming (by GM) to dirty throttle body.
 

·
Registered
Joined
·
2,388 Posts
So my girlfriend has been telling me about this weird issue she has when she tries to start her car. It is not very common, maybe once a month I think. I have never been around to witness is till tonight. She turned the key to start the car and it just cranked for a longer than normal period of time and then it turned over for a split second and revved to 1000rpms and just stuttered and then died. It did this 4 times, and on the 5th time I lightly tapped the gas peddle and it started right up as if it wasn't getting fuel or something before. Never seen an issue like this before and was wondering if anyone else has had an issue similar. Car is a 2006 G6 GT 3.5 v6.
There are several possibilities.

It could be a early sign of a failing fuel pump. Could be a pressure or volume issue. Start by checking the fuel pressure during one of the no-start occurrences. I could look up the pressure range if you plan on DIY.
 
1 - 5 of 5 Posts
Top