Pontiac G6 Forum banner

1 - 20 of 41 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Anyone elses windshield wiper leave a "rub" mark on thier windshield at the end of thier travels? Mine leaves a vertical mark right in my line of sight.....its rather annoying.....am I being anal about it? :confused: :p
 

·
Registered
Joined
·
585 Posts
I haven't had that specific problem, but i do have one on my front side windows. Everytime we move the windows down and back up there is a line that appears on the outside of the window. i have no idea what is making the mark, but it just wipes off. Does anybody else have this problem?
 

·
Registered
Joined
·
73 Posts
I just noticed this same thing Monday after putting a real good cleaning on the car and the windows. Haven't tried to wipe them off or anything, but the fact that I noticed it AFTER cleaning the windows concerns me.
 

·
Registered
Joined
·
17 Posts
windshield wiper mark

I clean my windshield and blades and the mark comes back almost immediately. Has anyone ever found a permanent solution to this? I had it on my 2002 Grand Am as well as on my '06 G6.
 

·
Registered
Joined
·
17 Posts
Line on windshield

I don't have a picture but I was just told that the windshield is a laminate design. I am told that the laminate design is what causes the rubber to stick to the windshield at the point where the blade is at its max travel towards the drivers side and leaves a residue on the windshield.

I am told that using a wax that is free from any abrasives (good for clearcoat or fiberglass finishes) should help. I have not tried it yet, but I will.
 

·
Registered
Joined
·
19 Posts
hmm

:confused: I get this weird disfiguration on my rocker panel and scuff marks on my door when i back up into a wooden post. So wierd.
 

·
Registered
Joined
·
17 Posts
RainX

Well thanks for the useful and helpful information!!

Your attempts at humor are absolutley useless and serve no purpose.
I am trying to get a solution to a persistent problem and you are trying to be witty. You aren't.

For anyone who is interested, the wax did not work, but the Rainx appears to have helped. I won't really know until we get a longer period of rain than the 15-30 minute showers we have had recently.
 

·
Lifetime Member
Joined
·
3,269 Posts
i used rain x on my bent rocker panel and it didnt do anything!!! :confused:

loljk
:)


Geewhiz said:
A hammer will take that right out! J/K
:)

A sense of humor is a great asset. It puts thing into perspective. I often use humor in my life. I take only a few things in life so serious that humor is inappropriate. This forum isn’t one of them. On this forum humor is abound and I believe it is appropriate for the members that could be having a difficult time with one of their major expenses, a G6. If this is a problem with you, you might want to browse a different forum in which a sense of humor is absent.
For the record I found the comments very witty.:rolleyes:

divebuddydave said:
Your attempts at humor are absolutley useless and serve no purpose.
I am trying to get a solution to a persistent problem and you are trying to be witty. You aren't.

You can try using a new wiper blade, I have a feeling that the one you are currently using is an inexpensive one. Try the higher quality blades.
 

·
Registered
Joined
·
17 Posts
wiper blades

I have used brand new ($60) dealer purchased and brand new generic wiper blades. Neither made any difference. The line, with rubber residue comes back. I have cleaned the blades and windshield with freon cleaner, alcohol, windex, etc. No difference. So far, the only thing that shows any promise is RainX, even though I was advised by an "expert" that Rainx would make the problem worse. When you get desperate, you don't always listen to the "experts" anymore.

I don't believe there are any other options available, but would welcome any additional pertinent suggestions.

I love humor as much as the next guy, but in all honesty, when I get an e-mail that there is a new comment on the Forum, and the comment is totally unrelated to my original question and can actually be interpreted as sarcastic, I really have no use for that kind of humor.
 

·
Registered
Joined
·
106 Posts
I never had this problem with the original wiper blades. I now have some aftermarket blades, they were a really good brand but I'm blank now, and anyway, I thought they would do well since the factory ones are a little more expensive. But I definitely get that mark in my windshield and it's right in my driving view. It annoys the crap out of me. I see that someone said he had the problem with factory blades, too. I dunno. I just know I never had the issue til I got new (and good) blades. Next time I'm going to try factory ones, and then I'll go from there. at least they're easy to install, though!
 

·
Registered
Joined
·
21 Posts
Here are pictures of the problem.

I have a couple of pictures of the windshield marking problem. These are the GM stock wipers, 1 year old.







Steve
 

·
Lifetime Member
Joined
·
3,269 Posts
I guess we need to find the common denominator on this one. I have a 07 G6 GT, I live in the Baton Rouge area and I don't have this problem. You guys that do, where do you live?
Just thinking about it, it could be road film. Maybe some "glass scrub" to get the windshield really clean then see if the mark comes back. Its a thought.
 
1 - 20 of 41 Posts
Top